Sprache

InetAddress.GetByName(String) Methode

Definition

Bestimmt die IP-Adresse eines Hosts anhand des Hostnamens.

[Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")]
public static Java.Net.InetAddress GetByName(string? host);
[<Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")>]
static member GetByName : string -> Java.Net.InetAddress

Parameter

host
String

der angegebene Host oder null.

Gibt zurück

eine IP-Adresse für den angegebenen Hostnamen.

Attribute

Ausnahmen

wenn die Adresssuche fehlschlägt.

Hinweise

Bestimmt die IP-Adresse eines Hosts anhand des Hostnamens.

Der Hostname kann entweder ein Computername, z. B. "java.sun.com", oder eine textbezogene Darstellung seiner IP-Adresse sein. Wenn eine Literal-IP-Adresse angegeben wird, wird nur die Gültigkeit des Adressformats überprüft.

Für host die in literaler IPv6-Adresse angegebenes Formular wird entweder das in RFC 2732 definierte Formular oder das in RFC 2373 definierte Literal-IPv6-Adressformat akzeptiert. IPv6-Adressbereiche werden ebenfalls unterstützt. Eine Beschreibung der IPv6-Adressbereiche finden Sie hier.

Wenn der Host ist null , wird eine InetAddress Adresse der Loopbackschnittstelle zurückgegeben. Siehe RFC 3330 Abschnitt  2 und RFC 2373 Section 2.5.3.

Java Dokumentation für java.net.InetAddress.getByName(java.lang.String).

Teile dieser Seite sind Änderungen auf der Grundlage von Arbeiten, die von der Android Open Source Project erstellt und gemeinsam verwendet und gemäß den in der 2.5 Attribution License beschriebenen Begriffen verwendet werden.

Gilt für: