X509Certificate.SubjectAlternativeNames Propiedad
Definición
Importante
Parte de la información hace referencia a la versión preliminar del producto, que puede haberse modificado sustancialmente antes de lanzar la versión definitiva. Microsoft no otorga ninguna garantía, explícita o implícita, con respecto a la información proporcionada aquí.
Obtiene una colección inmutable de nombres alternativos de sujeto de la SubjectAltName extensión (OID = 2.
public virtual System.Collections.Generic.ICollection<System.Collections.Generic.IList<object>>? SubjectAlternativeNames { [Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")] get; }
[<get: Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")>]
member this.SubjectAlternativeNames : System.Collections.Generic.ICollection<System.Collections.Generic.IList<obj>>
Valor de propiedad
un inmutable Collection de nombres alternativos de sujeto (o null)
- Atributos
Excepciones
si se produce un error en la descodificación de la extensión.
Comentarios
Obtiene una colección inmutable de nombres alternativos de sujeto de la SubjectAltName extensión (OID = 2.5.29.17).
La definición ASN.1 de la SubjectAltName extensión es:
SubjectAltName ::= GeneralNames
GeneralNames :: = SEQUENCE SIZE (1..MAX) OF GeneralName
GeneralName ::= CHOICE {
otherName [0] OtherName,
rfc822Name [1] IA5String,
dNSName [2] IA5String,
x400Address [3] ORAddress,
directoryName [4] Name,
ediPartyName [5] EDIPartyName,
uniformResourceIdentifier [6] IA5String,
iPAddress [7] OCTET STRING,
registeredID [8] OBJECT IDENTIFIER}
Si este certificado no contiene una SubjectAltName extensión, null se devuelve. De lo contrario, se devuelve un Collection objeto con una entrada que representa cada uno de los GeneralName incluidos en la extensión. Cada entrada es una List cuya primera entrada es ( Integer el tipo de nombre, 0-8) y cuya segunda entrada es o String una matriz de bytes (el nombre, en forma codificada por cadena o ASN.1 DER, respectivamente).
Los nombres RFC 822, DNS y URI se devuelven como Strings, utilizando los formatos de cadena bien establecidos para esos tipos (sujetos a las restricciones incluidas en RFC 3280). Los nombres de dirección IPv4 se devuelven mediante la notación cuádruple de puntos. Los nombres de dirección IPv6 se devuelven con el formato "a1:a2:...:a8", donde a1-a8 son valores hexadecimales que representan las ocho partes de 16 bits de la dirección. Los nombres de OID se devuelven como s representados como Stringuna serie de enteros no negativo separados por puntos. Los nombres de directorio (nombres distintivos) se devuelven en formato de cadena RFC 2253 . No se define ningún formato de cadena estándar para otros nombres, nombres X.400, nombres de entidad EDI o cualquier otro tipo de nombres. Se devuelven como matrices de bytes que contienen el formato codificado de DER asN.1 del nombre.
Tenga en cuenta que el Collection devuelto puede contener más de un nombre del mismo tipo. Además, tenga en cuenta que el devuelto Collection es inmutable y las entradas que contienen matrices de bytes se clonan para protegerse frente a modificaciones posteriores.
Este método se agregó a la versión 1.4 del Java 2 Platform Standard Edition. Para mantener la compatibilidad con versiones anteriores con los proveedores de servicios existentes, este método no abstract es y proporciona una implementación predeterminada. Las subclases deben invalidar este método con una implementación correcta.
Agregado en la versión 1.4.
Java documentación para java.security.cert.X509Certificate.getSubjectAlternativeNames().
Las partes de esta página son modificaciones basadas en el trabajo creado y compartido por el Android y se usan según los términos descritos en creative Creative Commons 2.5 Attribution License.