InetAddress.GetByName(String) Méthode
Définition
Important
Certaines informations portent sur la préversion du produit qui est susceptible d’être en grande partie modifiée avant sa publication. Microsoft exclut toute garantie, expresse ou implicite, concernant les informations fournies ici.
Détermine l’adresse IP d’un hôte, en fonction du nom de l’hôte.
[Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")]
public static Java.Net.InetAddress GetByName(string? host);
[<Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")>]
static member GetByName : string -> Java.Net.InetAddress
Paramètres
- host
- String
l’hôte spécifié, ou null.
Retours
une adresse IP pour le nom d’hôte donné.
- Attributs
Exceptions
si la recherche d’adresses échoue.
Remarques
Détermine l’adresse IP d’un hôte, en fonction du nom de l’hôte.
Le nom d’hôte peut être un nom d’ordinateur, tel que «java.sun.com » ou une représentation textuelle de son adresse IP. Si une adresse IP littérale est fournie, seule la validité du format d’adresse est vérifiée.
Pour host spécifié dans l’adresse IPv6 littérale, le formulaire défini dans RFC 2732 ou le format d’adresse IPv6 littéral défini dans RFC 2373 est accepté. Les adresses délimitées IPv6 sont également prises en charge. Consultez cette page pour obtenir une description des adresses délimitées IPv6.
Si l’hôte est null alors un InetAddress représentant une adresse de l’interface de bouclage est retournée. Voir la section RFC 3330 ; 2 et RFC 2373 section ;2.5.3.
Documentation Java pour java.net.InetAddress.getByName(java.lang.String).
Les parties de cette page sont des modifications basées sur le travail créé et partagé par Android Open Source et utilisées en fonction des termes décrits dans la Creative Commons 2.5 Attribution License.