Langue

X509Certificate.SubjectAlternativeNames Propriété

Définition

Obtient une collection immuable de noms alternatifs d’objet de l’extension SubjectAltName ( OID = 2.

public virtual System.Collections.Generic.ICollection<System.Collections.Generic.IList<object>>? SubjectAlternativeNames { [Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")] get; }
[<get: Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")>]
member this.SubjectAlternativeNames : System.Collections.Generic.ICollection<System.Collections.Generic.IList<obj>>

Valeur de propriété

immuable Collection de noms alternatifs d’objet (ou null)

Attributs

Exceptions

si le décodage de l’extension échoue.

Remarques

Obtient une collection immuable de noms alternatifs d’objet de l’extension SubjectAltName (OID = 2.5.29.17).

La définition ASN.1 de l’extension SubjectAltName est la suivante :

SubjectAltName ::= GeneralNames

            GeneralNames :: = SEQUENCE SIZE (1..MAX) OF GeneralName

            GeneralName ::= CHOICE {
                 otherName                       [0]     OtherName,
                 rfc822Name                      [1]     IA5String,
                 dNSName                         [2]     IA5String,
                 x400Address                     [3]     ORAddress,
                 directoryName                   [4]     Name,
                 ediPartyName                    [5]     EDIPartyName,
                 uniformResourceIdentifier       [6]     IA5String,
                 iPAddress                       [7]     OCTET STRING,
                 registeredID                    [8]     OBJECT IDENTIFIER}

Si ce certificat ne contient pas d’extension SubjectAltName , null est retourné. Sinon, un Collection est retourné avec une entrée représentant chaque GeneralName élément inclus dans l’extension. Chaque entrée est une List entrée dont la première entrée est un Integer (le type de nom, 0-8) et dont la deuxième entrée est un String tableau d’octets (le nom, dans la chaîne ou dans le formulaire CODÉ ASN.1 DER, respectivement).

Les noms RFC 822, DNS et URI sont retournés en tant que Strings, à l’aide des formats de chaîne bien établis pour ces types (soumis aux restrictions incluses dans RFC 3280). Les noms d’adresses IPv4 sont retournés à l’aide de la notation quad en pointillés. Les noms d’adresses IPv6 sont retournés sous la forme « a1 :a2 :... :a8 », où a1-a8 sont des valeurs hexadécimales représentant les huit morceaux 16 bits de l’adresse. Les noms OID sont retournés sous la forme Stringd’une série d’entiers non nénégatifs séparés par des points. Et les noms de répertoires (noms uniques) sont retournés au format de chaîne RFC 2253 . Aucun format de chaîne standard n’est défini pour d’autresNames, X.400 noms, noms de tiers EDI ou tout autre type de noms. Ils sont retournés sous forme de tableaux d’octets contenant la forme codée ASN.1 DER du nom.

Notez que le Collection retour peut contenir plusieurs noms du même type. Notez également que le retour Collection est immuable et que toutes les entrées contenant des tableaux d’octets sont clonées pour vous protéger contre les modifications suivantes.

Cette méthode a été ajoutée à la version 1.4 du Java 2 Platform Standard Edition. Pour maintenir la compatibilité descendante avec les fournisseurs de services existants, cette méthode n’est pas abstract et fournit une implémentation par défaut. Les sous-classes doivent remplacer cette méthode par une implémentation correcte.

Ajouté dans la version 1.4.

Java documentation pour java.security.cert.X509Certificate.getSubjectAlternativeNames().

Les parties de cette page sont des modifications basées sur le travail créé et partagé par Android Open Source et utilisées en fonction des termes décrits dans la Creative Commons 2.5 Attribution License.

S’applique à