InetAddress.GetByName(String) Metodo
Definizione
Importante
Alcune informazioni sono relative alla release non definitiva del prodotto, che potrebbe subire modifiche significative prima della release definitiva. Microsoft non riconosce alcuna garanzia, espressa o implicita, in merito alle informazioni qui fornite.
Determina l'indirizzo IP di un host, in base al nome dell'host.
[Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")]
public static Java.Net.InetAddress GetByName(string? host);
[<Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")>]
static member GetByName : string -> Java.Net.InetAddress
Parametri
- host
- String
l'host specificato, o null.
Valori restituiti
un indirizzo IP per il nome host specificato.
- Attributi
Eccezioni
se la ricerca dell'indirizzo ha esito negativo.
Commenti
Determina l'indirizzo IP di un host, in base al nome dell'host.
Il nome host può essere un nome di computer, ad esempio "java.sun.com" o una rappresentazione testuale del relativo indirizzo IP. Se viene fornito un indirizzo IP letterale, viene verificata solo la validità del formato di indirizzo.
Per host specificato nell'indirizzo IPv6 letterale, il modulo definito in RFC 2732 o il formato di indirizzo IPv6 letterale definito in RFC 2373 viene accettato. Sono supportati anche gli indirizzi con ambito IPv6. Vedere qui per una descrizione degli indirizzi con ambito IPv6.
Se l'host è null un oggetto InetAddress che rappresenta un indirizzo dell'interfaccia di loopback viene restituito. Vedere la sezione RFC 3330 2 e RFC 2373 sezione 2.5.3.
per java.net.InetAddress.getByName(java.lang.String).
Le parti di questa pagina sono modifiche basate sul lavoro creato e condiviso dalla e usati in base ai termini descritti in Creative License 2.5 Attribution License.