Notatka
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
DOTYCZY:
Azure Data Factory
Azure Synapse Analytics
Napiwek
Data Factory w usłudze Microsoft Fabric jest następną generacją Azure Data Factory z prostszą architekturą, wbudowaną sztuczną inteligencją i nowymi funkcjami. Jeśli dopiero zaczynasz integrować dane, zacznij od Fabric Data Factory. Istniejące obciążenia ADF można zaktualizować do Fabric, aby uzyskać dostęp do nowych możliwości w zakresie nauki o danych, analiz w czasie rzeczywistym oraz raportowania.
Ten artykuł zawiera sugestie dotyczące rozwiązywania typowych problemów z Dynamics 365, usługą Dataverse (Common Data Service) i łącznikami Dynamics CRM w Azure Data Factory i Azure Synapse.
Kod błędu: DynamicsCreateServiceClientError
Komunikat:
This is a transient issue on Dynamics server side. Try to rerun the pipeline.Cause: Problem jest przejściowym problemem po stronie serwera Dynamics.
Zalecenie: Uruchom ponownie przepływ. Jeśli wystąpi błąd ponownie, spróbuj zmniejszyć równoległość. Jeśli problem będzie się powtarzać, skontaktuj się z pomocą techniczną Dynamics.
Brak kolumn podczas importowania schematu lub podglądu danych
Objawy: Podczas importowania schematu lub podglądu danych brakuje niektórych kolumn. Komunikat o błędzie:
The valid structure information (column name and type) are required for Dynamics source.Przyczyna: Ten problem jest zamierzony, ponieważ potoki Data Factory i Synapse nie są w stanie wyświetlić kolumn, które nie zawierają wartości w pierwszych 10 rekordach. Upewnij się, że dodane kolumny mają poprawny format.
Zalecenie: Ręcznie dodaj kolumny na karcie mapowania. Aby uzyskać więcej informacji, zobacz Jawne mapowanie.
Kod błędu: DynamicsMissingTargetForMultiTargetLookupField
Komunikat:
Cannot find the target column for multi-target lookup field: '%fieldName;'.Przyczyna: kolumna docelowa nie istnieje w źródle ani w mapowaniu kolumn.
Zalecenie:
- Upewnij się, że źródło zawiera kolumnę docelową.
- Dodaj kolumnę docelową w mapowaniu kolumn. Upewnij się, że kolumna ujścia ma format {fieldName}@EntityReference.
Kod błędu: DynamicsInvalidTargetForMultiTargetLookupField
Komunikat:
The provided target: '%targetName;' is not a valid target of field: '%fieldName;'. Valid targets are: '%validTargetNames;'Przyczyna: Nieprawidłowa nazwa jednostki jest podana jako jednostka docelowa pola odnośnika z wieloma elementami docelowymi.
Zalecenie: podaj prawidłową nazwę jednostki dla pola odwołania wieloobiektowego.
Kod błędu: DynamicsInvalidTypeForMultiTargetLookupField
Komunikat:
The provided target type is not a valid string. Field: '%fieldName;'.Przyczyna: Wartość w kolumnie docelowej nie jest ciągiem.
Zalecenie: podaj prawidłowy ciąg w kolumnie docelowej wyszukiwania wielokierunkowego.
Kod błędu: DynamicsFailedToRequestServer
Komunikat:
The Dynamics server or the network is experiencing issues. Check network connectivity or check Dynamics server log for more details.Cause: Serwer Dynamics jest niestabilny lub niedostępny albo występują problemy z siecią.
Recommendation: Aby uzyskać więcej informacji, sprawdź łączność sieciową lub sprawdź dziennik serwera Dynamics. Aby uzyskać dalszą pomoc, skontaktuj się z pomocą techniczną Dynamics.
Kod błędu: DynamicsFailedToConnect
Komunikat:
Failed to connect to Dynamics: %message;Przyczyny i zalecenia: Różne przyczyny mogą prowadzić do tego błędu. Zapoznaj się z poniższą listą, aby zapoznać się z możliwymi analizami przyczyn i powiązanymi zaleceniami.
Analiza przyczyny Zalecenie Widzisz ERROR REQUESTING ORGS FROM THE DISCOVERY SERVERFCB 'EnableRegionalDisco' is disabled.lubUnable to Login to Dynamics CRM, message:ERROR REQUESTING Token FROM THE Authentication context - USER intervention required but not permitted by prompt behavior AADSTS50079: Due to a configuration change made by your administrator, or because you moved to a new location, you must enroll in multi-factor authentication to access '00000007-0000-0000-c000-000000000000'w inny sposób, jeśli Twój przypadek użycia spełnia wszystkie z następujących trzech warunków:- Nawiązujesz połączenie z usługą Dynamics 365, Common Data Service lub Dynamics CRM.
- Używasz uwierzytelniania usługi Office365.
- Dzierżawca i użytkownik są skonfigurowani w Microsoft Entra ID dla dostępu warunkowego i/lub wymagane jest uwierzytelnianie wieloskładnikowe (zobacz to łącze do dokumentu usługi Dataverse).
W tych okolicznościach połączenie powiodło się przed 8.06.2021 r. Począwszy od 9.06.2021 r., połączenia zaczną zawodzić z powodu wycofania regionalnej Usługi Discovery (zobacz ten link).Jeśli dzierżawa i użytkownik są skonfigurowani w Microsoft Entra ID dla dostępu warunkowego i/lub wymagane jest uwierzytelnianie wieloskładnikowe, należy użyć "reprezentanta usługi Microsoft Entra" do uwierzytelnienia po 6/8/2021. Zapoznaj się z tym linkiem , aby uzyskać szczegółowe instrukcje. Jeśli w komunikacie o błędzie zostanie wyświetlony Office 365 auth with OAuth failed, oznacza to, że serwer może mieć pewne konfiguracje niezgodne z protokołem OAuth.- Skontaktuj się z zespołem wsparcia Dynamics, podając szczegółowy komunikat o błędzie, aby uzyskać pomoc.
- Można użyć uwierzytelniania jednostki usługi, a szczegóły znajdziesz w tym artykule: Przykład: Dynamics online, przy użyciu jednostki usługi Microsoft Entra i uwierzytelniania certyfikatu.
Jeśli w komunikacie o błędzie zostanie wyświetlony Unable to retrieve authentication parameters from the serviceUri, oznacza to, że albo wprowadziłeś niewłaściwy adres URL usługi Dynamics, albo serwer proxy/zapora blokują ruch.- Upewnij się, że w połączonej usłudze umieszczono prawidłowy identyfikator URI usługi.
- Jeśli używasz własnego środowiska Self Hosted IR, upewnij się, że zapora sieciowa/serwer proxy nie przechwytuje żądań do serwera Dynamics.
Jeśli zostanie wyświetlony An unsecured or incorrectly secured fault was received from the other partykomunikat o błędzie, oznacza to, że nieoczekiwane odpowiedzi zostały odebrane po stronie serwera.- Upewnij się, że nazwa użytkownika i hasło są poprawne, jeśli używasz uwierzytelniania Office 365.
- Upewnij się, że masz prawidłowy identyfikator URI usługi.
- Jeśli używasz regionalnego adresu URL crm (adres URL ma liczbę po "crm"), upewnij się, że używasz poprawnego identyfikatora regionalnego.
- Aby uzyskać pomoc, skontaktuj się z zespołem pomocy technicznej Dynamics.
Jeśli zostanie wyświetlony No Organizations Foundkomunikat o błędzie, oznacza to, że nazwa organizacji jest nieprawidłowa lub użyto nieprawidłowego identyfikatora regionu CRM w adresie URL usługi.- Upewnij się, że masz prawidłowy identyfikator URI usługi.
- Jeśli używasz regionalnego adresu URL CRM (adres URL ma liczbę po "crm"), upewnij się, że używasz poprawnego identyfikatora regionalnego.
- Aby uzyskać pomoc, skontaktuj się z zespołem pomocy technicznej Dynamics.
Jeśli widzisz komunikat o błędzie powiązany z 401 Unauthorizedi Microsoft Entra, oznacza to, że występuje problem z jednostką usługi.Postępuj zgodnie ze wskazówkami w komunikacie o błędzie, aby rozwiązać problem z głównym elementem usługi. W przypadku innych błędów zazwyczaj problem występuje po stronie serwera. Użyj narzędzia XrmToolBox , aby nawiązać połączenie. Jeśli błąd będzie się powtarzać, skontaktuj się z zespołem pomocy technicznej Dynamics, aby uzyskać pomoc.
Kod błędu: DynamicsOperationFailed
Komunikat:
Dynamics operation failed with error code: %code;, error message: %message;.Przyczyna: Operacja nie powiodła się po stronie serwera.
Recommendation: Wyodrębnij kod błędu operacji Dynamics z komunikatu o błędzie:
Dynamics operation failed with error code: {code}i zapoznaj się z artykułem Kody błędów usługi Web w celu uzyskania bardziej szczegółowych informacji. W razie potrzeby możesz skontaktować się z zespołem pomocy technicznej Dynamics.
Kod błędu: DynamicsInvalidFetchXml
Komunikat:
The Fetch Xml query specified is invalid.Przyczyna: W pliku XML pobierania wystąpił błąd.
Zalecenie: Napraw błąd podczas pobierania kodu XML.
Kod błędu: DynamicsMissingKeyColumns
Komunikat:
Input DataSet must contain keycolumn(s) in Upsert/Update scenario. Missing key column(s): %column;Przyczyna: Dane źródłowe nie zawierają kolumny klucza dla jednostki ujścia.
Zalecenie: Upewnij się, że kluczowe kolumny znajdują się w danych źródłowych lub zamapuj kolumnę źródłową na kolumnę klucza dla jednostki docelowej.
Kod błędu: DynamicsPrimaryKeyMustBeGuid
Komunikat:
The primary key attribute '%attribute;' must be of type guid.Przyczyna: Typ kolumny klucza podstawowego nie jest GUID.
Zalecenie: upewnij się, że kolumna klucza podstawowego w danych źródłowych ma typ "Guid".
Kod błędu: DynamicsAlternateKeyNotFound
Komunikat:
Cannot retrieve key information of alternate key '%key;' for entity '%entity;'.Przyczyna: podany klucz alternatywny nie istnieje, co może być spowodowane przez nieprawidłowe nazwy kluczy lub niewystarczające uprawnienia.
Zalecenie:
- Napraw literówki w nazwie klucza.
- Upewnij się, że masz wystarczające uprawnienia w odniesieniu do jednostki.
- Napraw literówki w nazwie klucza.
Kod błędu: DynamicsInvalidSchemaDefinition
Komunikat:
The valid structure information (column name and type) are required for Dynamics source.Przyczyna: Kolumnom ujścia w mapowaniu kolumn brakuje właściwości "type".
Zalecenie: właściwość "type" można dodać do tych kolumn w mapowaniu kolumn przy użyciu edytora JSON w portalu.
Kod błędu: UserErrorUnsupportedAttributeType
Komunikat:
The attribute type 'Lookup' of field %attributeName; is not supportedCause: Podczas ładowania danych do ujścia Dynamics Azure Data Factory wymusza walidację metadanych atrybutu odnośnika. Jednak istnieje znany problem, że niektóre jednostki Dynamics nie mają prawidłowo zdefiniowanych metadanych atrybutu odnośnika, które zawierają listę obiektów docelowych, co może prowadzić do niepowodzenia weryfikacji.
Recommendation: Skontaktuj się z zespołem pomocy technicznej Dynamics, aby rozwiązać ten problem.
Działanie kopiowania z Dynamics 365 odczytuje więcej wierszy niż jest ich faktycznie.
Symptoms: Działanie kopiowania z Dynamics 365 odczytuje więcej wierszy, niż wynosi rzeczywista liczba.
Cause: Serwer Dynamics 365 zawsze wskazuje więcej dostępnych rekordów.
Zalecenie: Użyj narzędzia XrmToolBox , aby przetestować kod FetchXML z stronicowaniem. Narzędzie XrmToolBox z niektórymi zainstalowanymi narzędziami może pobierać liczbę rekordów. Aby uzyskać więcej informacji, zobacz XrmToolBox.
Nie można uzyskać dostępu do kolumn wirtualnych ze źródeł Dynamics w działaniu kopiowania
Symptoms: Nie można uzyskać dostępu do kolumn wirtualnych z źródeł Dynamics w operacji kopiowania.
Przyczyna: kolumna wirtualna nie jest teraz obsługiwana.
Zalecenie: W przypadku wartości Zestawu opcji postępuj zgodnie z poniższymi opcjami, aby ją pobrać:
- Możesz połączyć jednostkę StringMap z jednostką docelową i uzyskać skojarzone wartości.
Równoległa kopia w magazynie danych Dynamics CRM
Symptoms: Nie wiesz, czy istnieje możliwość skonfigurowania kopii równoległej w magazynie danych Dynamics CRM, a także nie znasz zakresu wartości, które można ustawić w sekcji "Stopień równoległości kopiowania".
Zalecenie: Sterowanie równoległością kopiowania określa równoległość, a sekcja „Stopień równoległości kopiowania” może być ustawiona na wartość inną niż zero. Duża liczba może spowodować ograniczenie przepustowości po stronie serwera dynamics, co może zmniejszyć przepływność, ale teraz ograniczanie jest obsługiwane przez użycie publicznego zestawu SDK.
Konwersja typu w Dynamics
Symptoms: próbujesz przekonwertować identyfikator GUID na ciąg w źródle Dynamics, ale napotykasz błąd.
Cause: Gdy Dynamics jest używana jako źródło, konwersja typu nie jest obsługiwana.
Zalecenie: Włącz etapowanie i ponowienie.
Powiązana zawartość
Aby uzyskać pomoc dotyczącą rozwiązywania problemów, wypróbuj następujące zasoby: