Rozwiązywanie problemów z łącznikami Azure Synapse Analytics, Azure SQL Database, SQL Server, Azure SQL Managed Instance i Amazon RDS dla SQL Server w Azure Data Factory i Azure Synapse

DOTYCZY: Azure Data Factory Azure Synapse Analytics

Napiwek

Data Factory w usłudze Microsoft Fabric jest następną generacją Azure Data Factory z prostszą architekturą, wbudowaną sztuczną inteligencją i nowymi funkcjami. Jeśli dopiero zaczynasz integrować dane, zacznij od Fabric Data Factory. Istniejące obciążenia ADF można zaktualizować do Fabric, aby uzyskać dostęp do nowych możliwości w zakresie nauki o danych, analiz w czasie rzeczywistym oraz raportowania.

Ten artykuł zawiera sugestie dotyczące rozwiązywania typowych problemów z łącznikami Azure Synapse Analytics, Azure SQL Database, SQL Server, Azure SQL Managed Instance oraz łącznikiem Amazon RDS dla SQL Server w Azure Data Factory i Azure Synapse.

Kod błędu: SqlFailedToConnect

  • Komunikat: Cannot connect to SQL Database: '%server;', Database: '%database;', User: '%user;'. Check the linked service configuration is correct, and make sure the SQL Database firewall allows the integration runtime to access.

  • Przyczyny i zalecenia: Różne przyczyny mogą prowadzić do tego błędu. Zapoznaj się z poniższą listą, aby zapoznać się z możliwą analizą przyczyn i powiązanymi zaleceniami.

    Analiza przyczyny Zalecenie
    W przypadku Azure SQL, jeśli komunikat o błędzie zawiera ciąg "SqlErrorNumber=47073", oznacza to, że dostęp do sieci publicznej jest blokowany w ustawieniu łączności. W zaporze Azure SQL ustaw opcję Odmowa dostępu do sieci publicznej na Nie. Aby uzyskać więcej informacji, zobacz Azure SQL ustawienia łączności.
    Dla Azure SQL, jeśli komunikat o błędzie zawiera kod błędu SQL, taki jak "SqlErrorNumber=[errorcode]", zobacz przewodnik rozwiązywania problemów z Azure SQL. Aby uzyskać rekomendację, zobacz Rozwiązywanie problemów z łącznością oraz inne błędy związane z Azure SQL Database i Azure SQL Managed Instance.
    Sprawdź, czy port 1433 znajduje się na liście dozwolonych zapory sieciowej. Aby uzyskać więcej informacji, zobacz Porty używane przez SQL Server.
    Jeśli komunikat o błędzie zawiera ciąg "SqlException", usługa SQL Database wskazuje, że określona operacja nie powiodła się. Aby uzyskać więcej informacji, wyszukaj według kodu błędu SQL w Błędy silnika bazy danych. Aby uzyskać dalszą pomoc, skontaktuj się z pomocą techniczną Azure SQL.
    Jeśli jest to przejściowy problem (na przykład niestabilne połączenie sieciowe), dodaj ponowienie w zasadach działań, aby rozwiązać ten problem. Aby uzyskać więcej informacji, zobacz Potoki i działania.
    Jeśli komunikat o błędzie zawiera ciąg "Klient z adresem IP" ... " nie może uzyskać dostępu do serwera", a próbujesz nawiązać połączenie z Azure SQL Database, błąd jest zwykle spowodowany problemem z zaporą Azure SQL Database. W konfiguracji zapory Azure SQL Server włącz opcję Zezwalaj usługom i zasobom Azure na dostęp do tego serwera. Aby uzyskać więcej informacji, zobacz reguły zapory IP dla Azure SQL Database i Azure Synapse.
    Jeśli komunikat o błędzie zawiera Login failed for user '<token-identified principal>', ten błąd jest zwykle spowodowany brakiem udzielenia wystarczających uprawnień dla głównego użytkownika usługi, systemowo przypisanej tożsamości zarządzanej lub przypisanej przez użytkownika tożsamości zarządzanej (w zależności od wybranego typu uwierzytelniania) w twojej bazie danych. Przyznaj wystarczające uprawnienia jednostce usługi lub tożsamości zarządzanej przypisanej przez system lub tożsamości zarządzanej przypisanej przez użytkownika w bazie danych.

    W przypadku usługi Azure SQL Database:
        — Jeśli używasz uwierzytelniania jednostki usługi, postępuj zgodnie z uwierzytelnianiem jednostki usługi.
        — Jeśli używasz uwierzytelniania tożsamości zarządzanej przypisanej przez system, postępuj zgodnie z uwierzytelnianiem tożsamości zarządzanej przypisanej przez system.
        Jeśli używasz uwierzytelniania tożsamości zarządzanej przypisanej przez użytkownika, skorzystaj z Uwierzytelniania tożsamości zarządzanej przypisanej przez użytkownika.
       
    W przypadku usługi Azure Synapse Analytics:
        — Jeśli używasz uwierzytelniania jednostki usługi, postępuj zgodnie z uwierzytelnianiem jednostki usługi.
        — Jeśli korzystasz z uwierzytelniania za pomocą tożsamości zarządzanej przypisanej przez system, postępuj według wskazówek w Tożsamości zarządzane przypisane przez system dla uwierzytelniania zasobów Azure.
        Jeśli używasz uwierzytelniania tożsamości zarządzanej przypisanej przez użytkownika, skorzystaj z Uwierzytelniania tożsamości zarządzanej przypisanej przez użytkownika.
       
    For Azure SQL Managed Instance:
        — Jeśli używasz uwierzytelniania jednostki usługi, postępuj zgodnie z uwierzytelnianiem jednostki usługi.
       — Jeśli używasz uwierzytelniania tożsamości zarządzanej przypisanej przez system, postępuj zgodnie z uwierzytelnianiem tożsamości zarządzanej przypisanej przez system.
       Jeśli używasz uwierzytelniania tożsamości zarządzanej przypisanej przez użytkownika, skorzystaj z Uwierzytelniania tożsamości zarządzanej przypisanej przez użytkownika.
    Jeśli zostanie wyświetlony komunikat o błędzie zawierający The server was not found or was not accessible podczas korzystania z Azure SQL Managed Instance, ten błąd jest zwykle spowodowany brakiem włączenia publicznego punktu końcowego Azure SQL Managed Instance. Aby włączyć publiczny punkt końcowy w Azure SQL Managed Instance, zobacz Konfiguruj publiczny punkt końcowy w Azure SQL Managed Instance.

Kod błędu: SqlOperationFailed

  • Komunikat: A database operation failed. Please search error to get more details.

  • Przyczyny i zalecenia: Różne przyczyny mogą prowadzić do tego błędu. Zapoznaj się z poniższą listą, aby zapoznać się z możliwą analizą przyczyn i powiązanymi zaleceniami.

    Analiza przyczyny Zalecenie
    Jeśli komunikat o błędzie zawiera ciąg "SqlException", usługa SQL Database zgłasza błąd wskazujący, że określona operacja nie powiodła się. Jeśli błąd SQL nie jest jasny, spróbuj zmienić bazę danych na najnowszy poziom zgodności "150". Może zgłaszać błędy SQL najnowszej wersji. Więcej informacji znajduje się w dokumentacji.
    Aby uzyskać więcej informacji na temat rozwiązywania problemów z SQL, wyszukaj kod błędu SQL w Błędy silnika bazy danych. Aby uzyskać dalszą pomoc, skontaktuj się z pomocą techniczną Azure SQL.
    Jeśli komunikat o błędzie zawiera ciąg "PdwManagedToNativeInteropException", zwykle jest to spowodowane niezgodnością między rozmiarami kolumn źródłowych i docelowych. Sprawdź rozmiar kolumn źródłowych i ujścia. Aby uzyskać dalszą pomoc, skontaktuj się z pomocą techniczną Azure SQL.
    Jeśli komunikat o błędzie zawiera ciąg "InvalidOperationException", zwykle jest to spowodowane nieprawidłowymi danymi wejściowymi. Aby określić, który wiersz napotkał problem, włącz funkcję odporności na uszkodzenia w działaniu kopiowania, która może przekierowywać problematyczne wiersze do magazynu w celu dalszej analizy. Aby uzyskać więcej informacji, zobacz Odporność na awarie podczas kopiowania.
    Jeśli komunikat o błędzie zawiera komunikat "Upłynął limit czasu wykonania", zwykle jest to spowodowane przekroczeniem limitu czasu zapytania. Skonfiguruj przerwanie czasu zapytania w źródle i przerwanie czasu zapisu w ujściu w celu wydłużenia czasu.
    Jeśli komunikat o błędzie zawiera Cannot find the object "dbo.Contoso" because it does not exist or you do not have permissions. podczas kopiowania danych w środowisku hybrydowym do lokalnej tabeli SQL Server, przyczyną jest to, że bieżące konto SQL nie ma wystarczających uprawnień do wykonywania żądań wystawianych przez .NET SqlBulkCopy.WriteToServer albo tabela lub baza danych nie istnieje. Przejdź do bardziej uprzywilejowanego konta SQL lub sprawdź, czy tabela lub baza danych istnieje.

Kod błędu: SqlUnauthorizedAccess

  • Komunikat: Cannot connect to '%connectorName;'. Detail Message: '%message;'

  • Przyczyna: Poświadczenia są nieprawidłowe lub konto logowania nie może uzyskać dostępu do bazy danych SQL.

  • Zalecenie: Sprawdź, czy konto logowania ma wystarczające uprawnienia dostępu do bazy danych SQL.

Kod błędu: SqlOpenConnectionTimeout

  • Komunikat: Open connection to database timeout after '%timeoutValue;' seconds.

  • Przyczyna: Problem może być błędem przejściowym bazy danych SQL.

  • Rekomendacja: Ponów próbę zaktualizowania parametry połączenia powiązanej usługi z większą wartością czasu oczekiwania na połączenie.

Kod błędu: SqlAutoCreateTableTypeMapFailed

  • Komunikat: Type '%dataType;' in source side cannot be mapped to a type that supported by sink side(column name:'%columnName;') in autocreate table.

  • Przyczyna: Tabela automatycznego tworzenia nie może spełniać wymagań źródłowych.

  • Zalecenie: zaktualizuj typ kolumny w mapowaniach lub ręcznie utwórz tabelę ujścia na serwerze docelowym.

Kod błędu: SqlDataTypeNotSupported

  • Komunikat: A database operation failed. Check the SQL errors.

  • Przyczyna: Jeśli problem występuje w źródle SQL i błąd jest związany z przepełnieniem SqlDateTime, wartość danych przekracza zakres typów logiki (1/1/1753 12:00:00–12/31/9999 11:59:59 PM).

  • Zalecenie: rzutuj typ na ciąg znaków w źródłowym zapytaniu SQL lub podczas mapowania kolumn w module kopiowania zmień typ kolumny na String.

  • Przyczyna: Jeśli problem występuje w ujściu SQL i błąd jest związany z przepełnieniem SqlDateTime, wartość danych przekracza dozwolony zakres w tabeli ujścia.

  • Zalecenie: zaktualizuj odpowiedni typ kolumny na datetime2 w tabeli ujścia.

Kod błędu: SqlInvalidDbStoredProcedure

  • Komunikat: The specified Stored Procedure is not valid. It could be caused by that the stored procedure doesn't return any data. Invalid Stored Procedure script: '%scriptName;'.

  • Przyczyny i zalecenia: Różne przyczyny mogą prowadzić do tego błędu. Zapoznaj się z poniższą listą, aby zapoznać się z możliwą analizą przyczyn i powiązanymi zaleceniami.

    Analiza przyczyny Zalecenie
    Określona procedura składowana jest nieprawidłowa. Zweryfikuj procedurę składowaną za pomocą narzędzi SQL Tools. Upewnij się, że procedura składowana jest w stanie zwracać dane.
    Działanie Lookup wymaga, aby procedura składowana zwróciła pewną wartość, ale kod procedury składowanej nie zwraca żadnej wartości. Użyj działania procedury składowanej, jeśli procedura składowana ma nie zwracać żadnych danych.

Kod błędu: SqlInvalidDbQueryString

  • Komunikat: The specified SQL Query is not valid. It could be caused by that the query doesn't return any data. Invalid query: '%query;'

  • Przyczyna: Określone zapytanie SQL jest nieprawidłowe. Przyczyną może być to, że zapytanie nie zwraca żadnych danych.

  • Zalecenie: Zweryfikuj zapytanie SQL przy użyciu narzędzi SQL Tools. Upewnij się, że zapytanie może zwracać dane.

Kod błędu: SqlInvalidColumnName

  • Komunikat: Column '%column;' does not exist in the table '%tableName;', ServerName: '%serverName;', DatabaseName: '%dbName;'.

  • Przyczyna: nie można odnaleźć kolumny, ponieważ konfiguracja może być niepoprawna.

  • Zalecenie: Sprawdź kolumnę w zapytaniu, strukturę w zestawie danych i mapowania w działaniu.

Kod błędu: SqlBatchWriteTimeout

  • Komunikat: Timeouts in SQL write operation.

  • Przyczyna: Problem może być spowodowany błędem przejściowym bazy danych SQL.

  • Zalecenie: Spróbuj ponownie wykonać operację. Jeśli problem będzie się powtarzać, skontaktuj się z pomocą techniczną Azure SQL.

Kod błędu: SqlBatchWriteTransactionFailed

  • Komunikat: SQL transaction commits failed.

  • Przyczyna: Jeśli szczegóły wyjątku stale wskazują limit czasu transakcji, opóźnienie sieci między środowiskiem Integration Runtime i bazą danych jest większe niż domyślny próg 30 sekund.

  • Recommendation: Zaktualizuj parametry połączenia usługi połączonej SQL, ustawiając limit czasu połączenia na wartość równą lub większą niż 120 i ponownie uruchom aktywność.

  • Przyczyna: Jeśli szczegóły wyjątku sporadycznie wskazują, że połączenie SQL jest uszkodzone, może to być przejściowy błąd sieci lub problem po stronie bazy danych SQL.

  • Zalecenie: spróbuj ponownie wykonać działanie i przejrzyj metryki po stronie bazy danych SQL.

Kod błędu: SqlBulkCopyInvalidColumnLength

  • Komunikat: SQL Bulk Copy failed due to receive an invalid column length from the bcp client.

  • Przyczyna: Kopiowanie zbiorcze SQL nie powiodło się, ponieważ odebrano nieprawidłową długość kolumny od klienta narzędzia programu kopiowania zbiorczego (bcp).

  • Zalecenie: Aby określić, który wiersz napotkał problem, włącz funkcję odporności na uszkodzenia w działaniu kopiowania. Może to przekierowywać problematyczne wiersze do magazynu w celu dalszego zbadania. Aby uzyskać więcej informacji, zobacz Odporność na awarie podczas kopiowania.

Kod błędu: SqlConnectionIsClosed

  • Komunikat: The connection is closed by SQL Database.

  • Przyczyna: Połączenie SQL jest zamykane przez bazę danych SQL, gdy występuje duże obciążenie współbieżne, a serwer przerywa połączenie.

  • Zalecenie: spróbuj ponownie nawiązać połączenie. Jeśli problem będzie się powtarzać, skontaktuj się z pomocą techniczną Azure SQL.

Kod błędu: SqlServerInvalidLinkedServiceCredentialMissing

  • Komunikat: The SQL Server linked service is invalid with its credential being missing.

  • Przyczyna: Połączona usługa nie została prawidłowo skonfigurowana.

  • Zalecenie: Zweryfikuj i napraw powiązaną usługę SQL Server.

Kod błędu: SqlParallelFailedToDetectPartitionColumn

  • Komunikat: Failed to detect the partition column with command '%command;', %message;.

  • Przyczyna: w tabeli nie ma klucza podstawowego ani unikatowego klucza.

  • Zalecenie: Sprawdź tabelę, aby upewnić się, że został utworzony klucz podstawowy lub unikatowy indeks.

Kod błędu: SqlParallelFailedToDetectPhysicalPartitions

  • Komunikat: Failed to detect the physical partitions with command '%command;', %message;.

  • Przyczyna: dla tabeli nie są tworzone partycje fizyczne. Sprawdź bazę danych.

  • Zalecenie: Zobacz Create Partitioned Tables and Indexes w celu rozwiązania tego problemu.

Kod błędu: SqlParallelFailedToGetPartitionRangeSynapse

  • Komunikat: Failed to get the partitions for azure synapse with command '%command;', %message;.

  • Przyczyna: dla tabeli nie są tworzone partycje fizyczne. Sprawdź bazę danych.

  • Zalecenie: Odnieś się do tabel partycjonowanych w dedykowanej puli SQL w celu rozwiązania tego problemu.

Komunikat o błędzie: Konwersja nie powiodła się podczas konwertowania z ciągu znaku na uniqueidentifier

  • Symptoms: Podczas kopiowania danych ze źródła danych tabelarycznych (takich jak SQL Server) do Azure Synapse Analytics przy użyciu kopiowania etapowego i technologii PolyBase występuje następujący błąd:

    ErrorCode=FailedDbOperation,Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException, Message=Error happened when loading data into Azure Synapse Analytics., Source=Microsoft.DataTransfer.ClientLibrary,Type=System.Data.SqlClient.SqlException, Message=Conversion failed when converting from a character string to uniqueidentifier...

  • Cause: Azure Synapse Analytics PolyBase nie może przekonwertować pustego ciągu na identyfikator GUID.

  • Rozwiązanie: w ujściu działania kopiowania w obszarze Ustawienia programu PolyBase ustaw opcję użycie domyślnego typu na false.

Komunikat o błędzie: Oczekiwany typ danych: DECIMAL(x,x), Nieprawidłowa wartość

  • Symptoms: Podczas kopiowania danych ze źródła danych tabelarycznych (na przykład SQL Server) do Azure Synapse Analytics przy użyciu kopiowania etapowego i technologii PolyBase występuje następujący błąd:

    ErrorCode=FailedDbOperation,Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException, Message=Error happened when loading data into Azure Synapse Analytics., Source=Microsoft.DataTransfer.ClientLibrary,Type=System.Data.SqlClient.SqlException, Message=Query aborted-- the maximum reject threshold (0 rows) was reached while reading from an external source: 1 rows rejected out of total 415 rows processed. (/file_name.txt) Column ordinal: 18, Expected data type: DECIMAL(x,x), Offending value:..

  • Cause: Azure Synapse Analytics PolyBase nie może wstawić pustego ciągu (wartości null) do kolumny dziesiętnej.

  • Rozwiązanie: w narzędziu kopiowania działań, w obszarze Ustawienia PolyBase, ustaw opcję use type default na wartość false.

Komunikat o błędzie: komunikat o wyjątku Java: HdfsBridge::CreateRecordReader

  • Symptoms: Dane są kopiowane do Azure Synapse Analytics przy użyciu technologii PolyBase i są wyświetlane następujące błędy:

    Message=110802;An internal DMS error occurred that caused this operation to fail. Details: Exception: Microsoft.SqlServer.DataWarehouse.DataMovement.Common.ExternalAccess.HdfsAccessException, Message: Java exception raised on call to HdfsBridge_CreateRecordReader. Java exception message:HdfsBridge::CreateRecordReader - Unexpected error encountered creating the record reader.: Error [HdfsBridge::CreateRecordReader - Unexpected error encountered creating the record reader.] occurred while accessing external file.....

  • Przyczyna: Przyczyną może być zbyt duży schemat (całkowita szerokość kolumny) (większy niż 1 MB). Sprawdź schemat tabeli Azure Synapse Analytics docelowej, dodając rozmiar wszystkich kolumn:

    • Int = 4 bajty
    • Bigint = 8 bajtów
    • Varchar(n), char(n), binary(n), varbinary(n) = n bajtów
    • Nvarchar(n), nchar(n) = n*2 bajtów
    • Data = 6 bajtów
    • Datetime/(2), smalldatetime = 16 bajtów
    • Datetimeoffset = 20 bajtów
    • Liczba dziesiętna = 19 bajtów
    • Liczba zmiennoprzecinkowa = 8 bajtów
    • Pieniądze = 8 bajtów
    • Smallmoney = 4 bajty
    • Wartość rzeczywista = 4 bajty
    • Smallint = 2 bajty
    • Czas = 12 bajtów
    • Tinyint = 1 bajt
  • Rozwiązanie:

    • Zmniejsz szerokość kolumny do mniej niż 1 MB.
    • Możesz też użyć metody wstawiania zbiorczego, wyłączając program PolyBase.

Komunikat o błędzie: Warunek określony przy użyciu nagłówków warunkowych HTTP nie jest spełniony

  • Objawy: Używasz zapytania SQL, aby pobrać dane z Azure Synapse Analytics i występuje następujący błąd:

    ...StorageException: The condition specified using HTTP conditional header(s) is not met...

  • Cause: Azure Synapse Analytics napotkał problem podczas wykonywania zapytań względem tabeli zewnętrznej w Azure Storage.

  • Resolution: Uruchom to samo zapytanie w programie SQL Server Management Studio (SSMS) i sprawdź, czy otrzymasz ten sam wynik. Jeśli tak, otwórz bilet pomocy technicznej do usługi Azure Synapse Analytics i podaj nazwę serwera oraz bazy danych Azure Synapse Analytics.

Poziom wydajności jest niski i prowadzi do niepowodzenia kopiowania

  • Symptoms: Skopiuj dane do Azure SQL Database i zostanie wyświetlony następujący błąd: Database operation failed. Error message from database execution : ExecuteNonQuery requires an open and available Connection. The connection's current state is closed.

  • Cause: Azure SQL Database s1 osiągnęła limity wejścia/wyjścia (I/O).

  • Resolution: Uaktualnij warstwę wydajności Azure SQL Database, aby rozwiązać ten problem.

Komunikat o błędzie: Ciąg lub dane binarne są obcięte

  • Symptoms: Wystąpił błąd podczas kopiowania danych do lokalnej tabeli usługi Azure SQL Server.

  • Przyczyna: Definicja schematu tabeli SQL ma co najmniej jedną kolumnę o mniejszej długości niż oczekiwano.

  • Rozwiązanie: Aby rozwiązać ten problem, spróbuj wykonać następujące czynności:

    1. Aby zidentyfikować, które wiersze mają problem, zastosuj odporność na błędy w ujściu SQL, szczególnie redirectIncompatibleRowSettings.

      Uwaga

      Odporność na uszkodzenia może wymagać dodatkowego czasu wykonywania, co może prowadzić do wyższych kosztów.

    2. Dokładnie sprawdź przekierowane dane względem długości kolumn schematu tabeli SQL, aby sprawdzić, które kolumny należy zaktualizować.

    3. Zaktualizuj odpowiednio schemat tabeli.

Kod błędu: FailedDbOperation

  • Komunikat: User does not have permission to perform this action.

  • Recommendation: Upewnij się, że użytkownik skonfigurowany w łączniku Azure Synapse Analytics musi mieć uprawnienie "CONTROL" w docelowej bazie danych podczas ładowania danych przy użyciu programu PolyBase. Aby uzyskać bardziej szczegółowe informacje, zapoznaj się z tym dokumentem.

Kod błędu: Msg 105208

  • Objawy: Kod błędu: Error code: Msg 105208, Level 16, State 1, Line 1 COPY statement failed with the following error when validating value of option 'FROM': '105200;COPY statement failed because the value for option 'FROM' is invalid.'
  • Przyczyna: Obecnie importowanie danych przy użyciu polecenia COPY do konta Azure Storage z nową funkcją podziału na partycje DNS powoduje błąd. Funkcja partycji DNS umożliwia klientom tworzenie maksymalnie 5000 kont magazynu na subskrypcję.
  • Resolutions: Aprowizacja konta magazynu w subskrypcji, która nie korzysta z nowej funkcji partycji DNS w Azure Storage (obecnie w publicznej wersji zapoznawczej).

Kod błędu: SqlDeniedPublicAccess

  • Komunikat: Cannot connect to SQL Database: '%server;', Database: '%database;', Reason: Connection was denied since Deny Public Network Access is set to Yes. To connect to this server, 1. If you persist public network access disabled, please use Managed Virtual Network IR and create private endpoint. https://docs.microsoft.com/en-us/azure/data-factory/managed-virtual-network-private-endpoint; 2. Otherwise you can enable public network access, set "Public network access" option to "Selected networks" on Azure SQL Networking setting.

  • Przyczyny: Baza danych Azure SQL jest skonfigurowana na zablokowanie dostępu do sieci publicznej. Wymaga to użycia zarządzanej sieci wirtualnej i utworzenia prywatnego punktu końcowego w celu uzyskania dostępu.

  • Zalecenie:

    1. Jeśli nalegasz na wyłączenie dostępu do sieci publicznej, użyj zarządzanego środowiska uruchomieniowego Integracji z siecią wirtualną i utwórz prywatny punkt końcowy. Aby uzyskać więcej informacji, zobacz Azure Data Factory zarządzana sieć wirtualna.

    2. W przeciwnym razie włącz dostęp do sieci publicznej, ustawiając ustawienie Dostęp do sieci publicznej na Wybrane sieci na stronie ustawień Networking w Azure SQL Database.

Aby uzyskać pomoc dotyczącą rozwiązywania problemów, wypróbuj następujące zasoby: