Uri.IsWellFormedUriString(String, UriKind) Metoda
Definicja
Ważne
Niektóre informacje odnoszą się do produktu w wersji wstępnej, który może zostać znacząco zmodyfikowany przed wydaniem. Firma Microsoft nie udziela żadnych gwarancji, jawnych lub domniemanych, w odniesieniu do informacji podanych w tym miejscu.
Wskazuje, czy ciąg jest poprawnie sformułowany, próbując skonstruować identyfikator URI z ciągiem i gwarantuje, że ciąg nie wymaga dalszego ucieczki.
public:
static bool IsWellFormedUriString(System::String ^ uriString, UriKind uriKind);
public static bool IsWellFormedUriString(string uriString, UriKind uriKind);
public static bool IsWellFormedUriString(string? uriString, UriKind uriKind);
static member IsWellFormedUriString : string * UriKind -> bool
Public Shared Function IsWellFormedUriString (uriString As String, uriKind As UriKind) As Boolean
Parametry
Zwraca
true jeśli ciąg został poprawnie sformułowany; w przeciwnym razie, false.
Uwagi
W wersjach .NET przed wersją 4.5 domyślnie ciąg jest uznawany za dobrze sformułowany zgodnie z RFC 2396 i RFC 2732. Jeśli włączono analizowanie międzynarodowych identyfikatorów zasobów (IRI) lub międzynarodowych nazw domen (IDN), ciąg jest uznawany za dobrze sformułowany zgodnie z RFC 3986 i RFC 3987.
Począwszy od .NET 4.5, ciągi są zawsze uznawane za dobrze sformułowane zgodnie z RFC 3986 i RFC 3987, niezależnie od tego, czy są włączone IRI, czy IDN. Należy jednak pamiętać, że dotyczy to tylko aplikacji przeznaczonych dla .NET 4.5 lub nowszej. Aplikacje przeznaczone dla .NET 4.0 wywołują kod zgodności i doświadczają starego zachowania (sprzed 4,5).
Ciąg jest uznawany za źle sformułowany, powodując, że metoda zwraca wartość false, jeśli wystąpi którykolwiek z poniższych warunków
| Error | Example |
|---|---|
| Ciąg nie został poprawnie uniknięty. | http://www.contoso.com/path???/file name |
| Ciąg jest bezwzględnym, Uri który reprezentuje niejawny plik Uri. | c:\\directory\filename |
| Ciąg jest bezwzględnym identyfikatorem URI, który nie ma ukośnika przed ścieżką. | file://c:/directory/filename |
| Ciąg zawiera niewyrażne ukośniki odwrotne, nawet jeśli będą traktowane jako ukośniki do przodu | http:\\\host/path/file |
| Ciąg reprezentuje hierarchiczną wartość bezwzględną Uri i nie zawiera ciągu "://" | www.contoso.com/path/file |
| Analizator dla elementu Scheme wskazuje, że oryginalny ciąg nie został poprawnie sformułowany. | Przykład zależy od schematu identyfikatora URI. |
| Począwszy od .NET 4,5, względne identyfikatory URI z dwukropkiem (':') w pierwszym segmencie nie są uważane za dobrze sformułowane. | 2013.05.29_14:33:41 |
Aby uzyskać więcej informacji na temat obsługi IRI, zobacz sekcję Uri Uwagi dla klasy.