InetAddress.GetByName(String) Método
Definição
Importante
Algumas informações se referem a produtos de pré-lançamento que podem ser substancialmente modificados antes do lançamento. A Microsoft não oferece garantias, expressas ou implícitas, das informações aqui fornecidas.
Determina o endereço IP de um host, dado o nome do host.
[Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")]
public static Java.Net.InetAddress GetByName(string? host);
[<Android.Runtime.Register("getByName", "(Ljava/lang/String;)Ljava/net/InetAddress;", "")>]
static member GetByName : string -> Java.Net.InetAddress
Parâmetros
- host
- String
o host especificado ou null.
Retornos
um endereço IP para o nome do host fornecido.
- Atributos
Exceções
se a pesquisa de endereço falhar.
Comentários
Determina o endereço IP de um host, dado o nome do host.
O nome do host pode ser um nome de computador, como "java.sun.com" ou uma representação textual de seu endereço IP. Se um endereço IP literal for fornecido, somente a validade do formato de endereço será verificada.
Para host especificado no endereço IPv6 literal, o formulário definido em RFC 2732 ou o formato de endereço IPv6 literal definido no RFC 2373 é aceito. Também há suporte para endereços com escopo IPv6. Veja aqui uma descrição dos endereços com escopo IPv6.
Se o host for null , um InetAddress endereço da interface de loopback será retornado. Consulte a seção RFC 3330 2 e RFC 2373 seção 2.5.3.
Documentação Java para java.net.InetAddress.getByName(java.lang.String).
Partes desta página são modificações baseadas no trabalho criado e compartilhado pelo Project Open Source do Open Source e usadas de acordo com os termos descritos na Creative Commons 2.5.