Idioma

X509Certificate.SubjectAlternativeNames Propriedade

Definição

Obtém uma coleção imutável de nomes alternativos de assunto da SubjectAltName extensão (OID = 2.

public virtual System.Collections.Generic.ICollection<System.Collections.Generic.IList<object>>? SubjectAlternativeNames { [Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")] get; }
[<get: Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")>]
member this.SubjectAlternativeNames : System.Collections.Generic.ICollection<System.Collections.Generic.IList<obj>>

Valor da propriedade

um imutável Collection de nomes alternativos de assunto (ou null)

Atributos

Exceções

se a decodificação da extensão falhar.

Comentários

Obtém uma coleção imutável de nomes alternativos de assunto da SubjectAltName extensão (OID = 2,5,29,17).

A definição asn.1 da SubjectAltName extensão é:

SubjectAltName ::= GeneralNames

            GeneralNames :: = SEQUENCE SIZE (1..MAX) OF GeneralName

            GeneralName ::= CHOICE {
                 otherName                       [0]     OtherName,
                 rfc822Name                      [1]     IA5String,
                 dNSName                         [2]     IA5String,
                 x400Address                     [3]     ORAddress,
                 directoryName                   [4]     Name,
                 ediPartyName                    [5]     EDIPartyName,
                 uniformResourceIdentifier       [6]     IA5String,
                 iPAddress                       [7]     OCTET STRING,
                 registeredID                    [8]     OBJECT IDENTIFIER}

Se esse certificado não contiver uma SubjectAltName extensão, null será retornado. Caso contrário, um Collection será retornado com uma entrada que representa cada GeneralName uma incluída na extensão. Cada entrada é uma List cuja primeira entrada é um Integer (o tipo de nome, 0-8) e cuja segunda entrada é uma String ou uma matriz de bytes (o nome, na cadeia de caracteres ou no formulário codificado em ASN.1 DER, respectivamente).

Os nomes RFC 822, DNS e URI são retornados como Strings, usando os formatos de cadeia de caracteres bem estabelecidos para esses tipos (sujeitos às restrições incluídas no RFC 3280). Os nomes de endereço IPv4 são retornados usando a notação quad pontilhada. Os nomes de endereço IPv6 são retornados no formato "a1:a2:...:a8", em que a1-a8 são valores hexadecimal que representam as oito partes de 16 bits do endereço. Os nomes OID são retornados como Strings representados como uma série de inteiros nãonegativos separados por períodos. E os nomes de diretório (nomes diferenciados) são retornados no formato de cadeia de caracteres RFC 2253 . Nenhum formato de cadeia de caracteres padrão é definido para outros Nomes, nomes X.400, nomes de partes EDI ou qualquer outro tipo de nomes. Elas são retornadas como matrizes de bytes que contêm a forma codificada em ASN.1 DER do nome.

Observe que o Collection retornado pode conter mais de um nome do mesmo tipo. Além disso, observe que o retornado Collection é imutável e todas as entradas que contêm matrizes de bytes são clonadas para proteger contra modificações subsequentes.

Esse método foi adicionado à versão 1.4 do Java 2 Platform Standard Edition. Para manter a compatibilidade com versões anteriores com provedores de serviços existentes, esse método não abstract é e fornece uma implementação padrão. As subclasses devem substituir esse método com uma implementação correta.

Adicionado em 1.4.

Documentação Java para java.security.cert.X509Certificate.getSubjectAlternativeNames().

Partes desta página são modificações baseadas no trabalho criado e compartilhado pelo Project Open Source do Open Source e usadas de acordo com os termos descritos na Creative Commons 2.5.

Aplica-se a