網路存取錯誤

本文說明在向 Azure 應用程式設定資料平面提出請求時可能發生的網路存取相關錯誤。

IP 位址被拒絕

錯誤回應

HTTP/1.1 403 Forbidden
Content-Type: application/problem+json; charset=utf-8
{
  "type": "https://azconfig.io/errors/ip-address-rejected",
  "title": "Access to this resource is governed by a network access policy. The client IP address fails to meet the criteria for access. See https://aka.ms/appconfig/network-access-errors for more information.",
  "status": 403
}

原因: 設定儲存庫中關閉了公共網路存取,且請求來源的 IP 位址不符合入站存取的標準。

解決方案: 當組態儲存庫關閉公共網路存取時,請求必須從虛擬網路內部透過私有端點發起。

  • 確認發出請求的用戶端是否在虛擬網路中,且相關的 DNS 變更 已就位,以確保組態儲存區的端點解析為連接至設定區的私有端點的 IP 位址。
  • 確認與私有端點相關的私有端點連線已被核准。

被網路安全邊界拒絕

錯誤回應

HTTP/1.1 403 Forbidden
Content-Type: application/problem+json; charset=utf-8
{
  "type": "https://azconfig.io/errors/nsp-rejected",
  "title": "Access to this resource is governed by a Network Security Perimeter. The request fails to meet the criteria for inbound access. See https://aka.ms/appconfig/network-access-errors for more information.",
  "status": 403
}

原因: App Configuration Store 的公開網路存取受網路安全邊界限制,請求不符合入站存取的標準。

解決方案: 當一個儲存裝置的公共網路存取受網路安全邊界所管轄時,請求必須從網路安全邊界內發出,或請求必須符合與該儲存裝置相關的網路安全邊界設定檔中定義的入站存取規則。

  • 確認提出請求的用戶端是否在網路安全邊界內,或請求符合與儲存裝置相關的網路安全邊界設定檔中定義的入站存取規則。