X509Certificate.SubjectAlternativeNames 屬性
定義
重要
部分資訊涉及發行前產品,在發行之前可能會有大幅修改。 Microsoft 對此處提供的資訊,不做任何明確或隱含的瑕疵擔保。
從擴充檔名(OID = 2)獲得一組不可變的主體替代名稱 SubjectAltName 集合。
public virtual System.Collections.Generic.ICollection<System.Collections.Generic.IList<object>>? SubjectAlternativeNames { [Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")] get; }
[<get: Android.Runtime.Register("getSubjectAlternativeNames", "()Ljava/util/Collection;", "GetGetSubjectAlternativeNamesHandler")>]
member this.SubjectAlternativeNames : System.Collections.Generic.ICollection<System.Collections.Generic.IList<obj>>
屬性值
主詞替代名稱的不變 Collection (或 null)
- 屬性
例外狀況
如果擴展碼解碼失敗。
備註
從擴充檔獲得不可變的主體替代名稱 SubjectAltName 集合,(OID = 2.5.29.17)。
ASN.1 對該 SubjectAltName 擴展的定義為:
SubjectAltName ::= GeneralNames
GeneralNames :: = SEQUENCE SIZE (1..MAX) OF GeneralName
GeneralName ::= CHOICE {
otherName [0] OtherName,
rfc822Name [1] IA5String,
dNSName [2] IA5String,
x400Address [3] ORAddress,
directoryName [4] Name,
ediPartyName [5] EDIPartyName,
uniformResourceIdentifier [6] IA5String,
iPAddress [7] OCTET STRING,
registeredID [8] OBJECT IDENTIFIER}
若此憑證未包含 SubjectAltName 擴充功能, null 則會回傳。 否則,回傳 a Collection 並代表擴展中包含的每個 GeneralName 項目。 每個項目的第一個 List 項目為 Integer (名稱類型 0-8),第二個項目為 a String 或位元組陣列(分別為字串或 ASN.1 DER 編碼形式)。
RFC 822、DNS 和 URI 名稱以 s 回傳 String,使用這些類型的既定字串格式(受 RFC 3280 限制限制)。 IPv4 位址名稱以虛點四邊符號回傳。 IPv6 位址名稱以「a1:a2:...:a8」的形式回傳,其中 a1-a8 是十六進位值,代表位址中八個 16 位元的部分。 OID 名稱以 s 形式回傳 String,以一系列非負整數表示,並以週期分隔。 而目錄名稱(區別名稱)則以 RFC 2253 字串格式回傳。 其他名稱、X.400 名稱、EDI 當事方名稱或其他類型名稱,沒有標準字串格式。 它們以包含 ASN.1 DER 編碼形式名稱的位元組陣列回傳。
請注意,回傳的 Collection 名稱可能包含多個相同類型的名稱。 另外,回傳 Collection 的條目是不可變的,且包含位元組陣列的條目都會被克隆,以防止後續修改。
此方法被加入 Java 2 平台標準版 1.4 版本。 為了維持與現有服務提供者的向下相容性,此方法未 abstract 被採用,並提供預設實作。 子類別應透過正確實作覆蓋此方法。
在 1.4 版本加入。
的 java.security.cert.X509Certificate.getSubjectAlternativeNames()Java 檔。
此頁面的部分是根據 Android 開放原始碼專案所建立和共用的工作進行修改,並根據 Creative Commons 2.5 屬性授權中所述的詞彙使用。