Uri.IsWellFormedOriginalString 方法
定義
重要
部分資訊涉及發行前產品,在發行之前可能會有大幅修改。 Microsoft 對此處提供的資訊,不做任何明確或隱含的瑕疵擔保。
表示用來構造此繩 Uri 是否為良好成形,且不需進一步脫離。
public:
bool IsWellFormedOriginalString();
public bool IsWellFormedOriginalString();
member this.IsWellFormedOriginalString : unit -> bool
Public Function IsWellFormedOriginalString () As Boolean
傳回
true如果弦是良好形成的;否則,。 false
備註
根據 RFC 2396 和 RFC 2732,該字串預設被視為良構。 若啟用國際資源識別碼(IRI)或國際化網域名稱(IDN)解析,該字串依據 RFC 3986 與 RFC 3987 被視為良形
若出現以下任一條件,該字串被視為不良,導致方法回傳 false。
| 錯誤 | 範例 |
|---|---|
| 弦未正確逃脫。 | http://www.contoso.com/path???/file name |
| 字串是一個 Uri 絕對字串,代表隱含檔案 Uri。 | c:\\directory\filename |
| 這串字串是絕對的 URI,路徑前少了一個斜線。 | file://c:/directory/filename |
| 字串包含未逃脫的反斜線,即使它們被視為前斜線。 | http:\\\host/path/file |
| 該字串代表一個階層式絕對 Uri 字串,且不包含「@」。 | www.contoso.com/path/file |
| 解析器 Uri.Scheme 表示原始字串並非良好形成。 | 範例依據 URI 的方案而定。 |
預設情況下,用於構造此的 Uri 字串依據 RFC 2396 與 RFC 2732 被視為良形。
當啟用國際資源識別碼(IRI)及國際化網域名稱(IDN)支援時,用於建構此資料 Uri 的字串依據 RFC 3986 與 RFC 3987 視為良構。 支援 IRI 的簡單碼名稱僅包含 ASCII 字元,且總是以 xn-- 前綴開頭。
欲了解更多關於IRI支援的資訊,請參閱該 Uri 課程備註區。