在 Fabric Data Warehouse 中暫停與繼續

適用於:✅ Microsoft Fabric 中的 SQL 分析端點與資料倉儲

Microsoft Fabric 容量可以暫停,以協助組織節省成本。 與其他工作負載類似,當 Fabric 容量暫停時,Fabric Data Warehouse 也會受到影響。

Microsoft Fabric 中的倉庫或湖倉無法單獨暫停。 若要深入瞭解如何暫停和繼續 Fabric 容量,請造訪暫停和繼續您的容量。

對使用者要求的影響

系統管理員可以隨時暫停作用中的 Fabric 容量,即使 SQL 語句正在執行也一樣。 當容量暫停時,使用者可以預期下列行為:

  • 新要求:一旦容量暫停,使用者就無法執行新的 SQL 陳述式或查詢。 這也包括 Fabric 入口網站上的活動,例如建立作業、載入資料格、開啟模型檢視、開啟視覺化查詢編輯器。 在容量暫停之後嘗試的任何新活動,都會傳回下列錯誤訊息 Unable to complete the action because this Fabric capacity is currently paused.
    • 在客戶端應用程式工具如 SQL Server Management Studio(SSMS)或 Visual Studio Code 的 MSSQL 擴充功能中,使用者登入暫停容量時會收到相同的錯誤文字,並附帶 SQL 錯誤代碼:24800。
    • 在用戶端應用程式工具如 SQL Server Management Studio(SSMS)或 Visual Studio Code 的 MSSQL 擴充功能中,使用者在容量暫停時嘗試對現有連線執行新的 TSQL 查詢,會看到相同的錯誤文字,並附帶 SQL 錯誤代碼:24802。
  • 執行中請求:任何開啟的請求,例如執行中的 SQL 語句,或在 SQL 查詢編輯器、視覺化查詢編輯器 或建模檢視上的活動,都會被取消並顯示錯誤訊息,如 Unable to complete the action because this Fabric capacity is currently paused.
  • 使用者交易:當容量在例如 BEGIN TRAN 和 COMMIT TRAN 類似的使用者交易中途暫停時,交易會回溯。

注意

拒絕新請求與取消飛行中請求的使用者體驗在 Fabric 入口網站與用戶端應用程式如 SQL Server Management Studio(SSMS)或 Visual Studio Code 的 MSSQL 擴充功能中保持一致。

對系統背景工作的影響

使用者啟動的工作一樣,當資源暫停時,正在運行的系統背景工作將被取消。 系統產生的陳述式範例包括中繼資料同步活動,以及為加快查詢執行速度而執行的其他背景工作。

某些清理活動在計算暫停時可能會受到影響。 例如,當容量暫停時,不會移除比目前資料保留設定還舊的歷程記錄資料。 一旦能力恢復,活動就會恢復正常。

對快取和效能的影響

當 Fabric 容量暫停時,倉儲計算資源會正常關機。 為了獲得最佳效能,快取必須隨時保持暖機狀態。 在這類情況下,建議不要暫停基礎容量。

當 Fabric 容量恢復時,它會使用清除的快取重新啟動資料倉儲計算資源,因此需要執行幾次,才能將相關資料新增至快取。 在繼續作業之後的這段期間,可能會察覺到效能變慢。

提示

在決定暫停基礎 Fabric 容量之前,請先權衡效能與成本。

對計費的影響

  • 當容量被手動暫停時,實際上會暫停所有 Microsoft Fabric 工作負載(包括 Warehouse)的計算計費。
  • 起始暫停工作流程之後,資料倉儲不會報告計算使用量。
  • OneLake 儲存體計費計量並未暫停。 當計算暫停時,您會繼續支付儲存體費用。

在此處了解更多關於帳單的影響:了解您的 Azure Fabric 容量帳單。

考量與限制

  • 在暫停時,客戶端應用程式工具如 SQL Server Management Studio(SSMS)或 Visual Studio Code 的 MSSQL 擴充功能中的執行中請求會收到通用錯誤訊息,這些訊息無法說明取消背後的意圖。 在此情況下,會出現幾條範例錯誤訊息,包括(不限於):
    • An existing connection was forcibly closed by the remote host
    • Internal error. Unable to properly update physical metadata. Please try the operation again and contact Customer Support Services if this persists.
    • A severe error occurred on the current command. The results, if any, should be discarded.
  • 一旦容量恢復,可能需要幾分鐘才能開始接受新請求。
  • 背景清理活動在計算暫停時可能會受到影響。 一旦能力恢復,活動就會恢復正常。

後續步驟