錯誤 4000 - 4999

錯誤

嚴重性

已記錄事件

描述 (訊息文字)

4001

10

否

用戶端傳送 sp_reset_connection,但同時間仍有暫止的要求,伺服器正在中斷連接。

4002

16

否

內送表格式資料流 (TDS) 通訊協定資料流不正確。資料流非預期地結束。

4004

16

否

在僅有 Unicode 定序中的 Unicode 資料或 ntext 資料,無法使用 DB-Library (例如 ISQL) 或是 ODBC 3.7 版本或更早的版本來傳送。

4005

16

否

無法在單一更新呼叫中,從一個以上的基礎資料表更新資料行。

4006

16

否

無法在單一刪除呼叫中,從一個以上的基礎資料表刪除資料列。

4007

16

否

無法更新或插入資料行 "%.*ls"。它可能是運算式。

4008

16

否

資料類型 varchar(max)、nvarchar(max)、varbinary(max) 以及 XML 無法在 SQL Server 2005 之前的用戶端驅動程式版本的計算子句中使用。請使用較新的用戶端驅動程式,重新提交查詢。

4009

16

否

內送表格式資料流 (TDS) 通訊協定資料流不正確。TDS 標頭中有錯誤。

4010

16

否

內送表格式資料流 (TDS) 通訊協定資料流不正確。查詢通知 TDS 標頭中有錯誤。

4011

16

否

內送表格式資料流 (TDS) 通訊協定資料流不正確。MARS TDS 標頭中有錯誤。

4012

16

否

發現無效的表格式資料流 (TDS) 定序。

4013

16

否

內送表格式資料流 (TDS) 通訊協定資料流不正確。遺漏了 Multiple Active Result Set (MARS) TDS 標頭。

4014

20

否

從網路讀取輸入資料流時發生嚴重錯誤。工作階段即將結束 (輸入錯誤: %d,輸出錯誤: %d)。

4015

16

否

登入 '%.*ls' 所要求的語言並不是這個 SQL Server 的官方名稱。已改用伺服器範圍的預設值 %.*ls。

4016

16

否

'login %.*ls' 所要求的語言並不是這個 SQL Server 的官方名稱。已改用使用者預設值 %.*ls。

4017

16

否

'login %.*ls' 所要求的語言或使用者預設語言 %.*ls 都不是這個 SQL Server 的官方語言名稱。已改用伺服器範圍的預設值 %.*ls。

4018

16

否

使用者預設語言 %.*ls 並不是這個 SQL Server 的官方語言名稱。已改用伺服器範圍的預設值 %.*ls。

4019

16

否

登入 '%.*ls' 所要求的語言並不是這個 SQL Server 的官方語言名稱。登入失敗。

4020

16

否

語言 %.*ls 的預設日期順序 '%.*ls' 無效。已改用 mdy。

4021

16

否

在不同於初始登入的狀態下,重新設定連接結果。登入失敗。

4022

16

否

預期大量載入資料卻未送出。批次即將結束。

4027

16

否

在磁帶機 '%ls' 上,為資料庫 '%ls' 的 %hs 裝載磁帶。

4028

16

否

已經到達磁帶結尾。請移除磁帶 '%ls' 並為資料庫 '%ls' 的 %hs 裝載下一個磁帶。

4030

10

否

裝置 '%ls' 上的媒體在 %hs 過期,不能覆寫。

4035

10

否

已處理資料庫 '%ls' 的 %I64d 頁,檔案 %d 上的檔案 '%ls'。

4037

16

否

使用者指定的 MEDIANAME "%.*ls" 與裝置 "%ls" 的 MEDIANAME "%ls" 不符。

4038

16

否

在裝置 '%ls' 上找不到檔案識別碼 %d。

4060

11

否

無法開啟登入所要求的資料庫 "%.*ls"。登入失敗。

4061

11

否

登入所要求的資料庫 "%.*ls" 和使用者預設資料庫均無法開啟。已改用 master 資料庫。

4062

11

否

無法開啟使用者預設資料庫。已改用 master 資料庫。

4063

11

否

無法開啟登入所要求的資料庫 "%.*ls"。已改用使用者預設資料庫 "%.*ls"。

4064

11

否

無法開啟使用者預設資料庫。登入失敗。

4065

16

是

使用者正在嘗試透過 ODS 使用 '%.*ls',但已不再受支援。

4066

16

否

大於 65535 的類型識別碼無法傳送到 SQL Server 2000 或更早版本隨附的用戶端。

4067

16

否

CLR 類型序列化失敗,因為指定的 Cookie 無效。

4068

20

否

sp_resetconnection 已視為遠端程序呼叫 (RPC) 批次的一部分送出,但並非批次中最後一個 RPC。即將結束此連接。

4069

16

否

輸出參數的最後值為 Null,無法傳送到參數不可以是 Null 的 6.5 用戶端。

4070

16

否

COMPUTE 子句中指定了超過 255 個資料行,而且此中繼資料無法傳送給 SQL Server 6.5 版用戶端。

4071

10

否

擴充程序 '%.*ls' 中的 XP 回呼函數 '%.*ls' 失敗,因為是在 INSERT-EXEC 陳述式內執行,但此陳述式不允許擴充程序傳送非結果集的資訊。

4072

10

否

擴充程序 '%.*ls' 中的 XP 回呼函數 '%.*ls' 失敗,因為擴充程序在 UDF 內呼叫,但此 UDF 不允許傳送資料。

4073

16

否

資料類型 varchar(max)、nvarchar(max)、varbinary(max)、XML 或其他大型物件類型的傳回值,無法傳回至 SQL Server 2005 之前的用戶端驅動程式版本。請使用較新的用戶端驅動程式,重新提交查詢。

4074

16

否

用戶端驅動程式不接受超過 65,535 個資料行的結果集。

4075

16

否

USE 資料庫陳述式失敗,因為舊用戶端驅動程式無法辨識資料庫定序 %.*ls。請嘗試升級用戶端作業系統或套用服務更新到資料庫用戶端軟體,或使用另一個定序。如果需要有關變更定序的詳細資訊,請參閱 SQL Server 線上叢書。

4076

16

否

ALTER DATABASE 陳述式失敗,因為舊用戶端驅動程式無法辨識資料庫定序 %.*ls。請嘗試升級用戶端作業系統或套用服務更新到資料庫用戶端軟體,或使用另一個定序。如果需要有關變更定序的詳細資訊,請參閱 SQL Server 線上叢書。

4077

20

否

此陳述式失敗,因為 sql_variant 值使用了舊用戶端驅動程式無法辨識的資料庫定序 %.*ls。請嘗試升級用戶端作業系統或套用服務更新到資料庫用戶端軟體,或使用另一個定序。如果需要有關變更定序的詳細資訊,請參閱 SQL Server 線上叢書。

4078

16

否

此陳述式失敗,因為資料行 '%.*ls' (ID=%d) 使用了舊用戶端驅動程式無法辨識的資料庫定序 %.*ls。請嘗試升級用戶端作業系統或套用服務更新到資料庫用戶端軟體,或使用另一個定序。如果需要有關變更定序的詳細資訊,請參閱 SQL Server 線上叢書。

4079

16

否

陳述式失敗,因為在傳送資料流時發生算術溢位。

4101

16

否

APPLY 右側的彙總無法參考左側的資料行。

4102

15

否

只有 UPDATE 和 DELETE 的目標資料表,以及明確的 FROM 子句中指定的資料表,可允許 READPAST 鎖定提示。

4103

15

否

%.*ls: 不允許暫存檢視。

4104

16

否

無法繫結多重部分 (Multi-Part) 識別碼 "%.*ls"。

4105

16

否

此內容的運算式中,不允許使用者定義函數、資料分割函數和資料行參考。

4106

16

否

查詢中若使用包含資料行集的資料表,就不允許使用非 ANSI 外部聯結 (*= 和 =*)。請將查詢變更成使用 ANSI 外部聯結。

4107

16

否

不允許使用 BCP 公用程式或使用 BULK INSERT,來插入遠端資料表或檢視。

4108

16

否

視窗型函數只能出現在 SELECT 或 ORDER BY 子句中。

4109

16

否

視窗型函數無法在另一個視窗型函數或彙總的內容中使用。

4110

16

否

引數類型 "%s" 對於 "%s" 的引數 %d 無效。

4111

16

否

CREATE SCHEMA 陳述式之後應為名稱或授權關鍵字。

4112

16

否

次序函數 "%.*ls" 必須有 ORDER BY 子句。

4113

16

否

%.*ls 不是有效的視窗型函數,並且無法與 OVER 子句同時使用。

4114

16

否

函數 '%.*ls' 僅能接受 %d 個引數。

4115

16

否

TOP 子句的引數中不允許參考資料行 "%.*ls"。此處只允許參考外部範圍或獨立運算式和子查詢的資料行。

4116

16

否

函數 'ntile' 只接受正整數或 bigint 運算式做為輸入內容。

4117

16

否

無法為查詢作業擷取資料表資料,因為資料表 "%.*ls" 的結構描述更動太頻繁。由於資料表 "%.*ls" 包含計算資料行,因此變更資料表結構描述後必須重新整理資料表的所有資料。請重試一次查詢作業,如果問題仍然存在,請使用 SQL Server Profiler 找出造成問題的結構描述改變作業。

4118

16

否

FOR UPDATE 子句中指定了無效的運算式。

4119

16

否

無法將預設值指派給有 CLR 類型之資料行的屬性 setter。

4120

16

否

使用者定義函數名稱無法以此內容的資料庫名稱做為前置詞。

4121

16

否

找不到資料行 "%.*ls" 或者使用者定義函數或彙總 "%.*ls",或是名稱模稜兩可。

4122

16

否

不允許遠端資料表值函數呼叫。

4124

16

否

為批次提供的參數無效。

4126

16

否

找不到全文檢索索引的資料行。

4127

16

否

至少有一個 COALESCE 的引數必須為 NULL 類型。

4128

16

否

執行遠端查詢時發生內部錯誤。請連絡您的 SQL Server 技術支援人員,並提供有關您要執行之查詢的詳細資料。

4129

16

否

內嵌函數 "%.*ls" 無法接受相互關聯的參數或子查詢,因為該函數使用全文檢索運算子。

4130

16

否

BULK 資料列集指定了重複的提示。

4131

16

否

編譯時間常值已在一或多個 OPTIMIZE FOR 子句中,多次指定給變數 "%.*ls"。

4132

16

否

在 OPTIMIZE FOR 子句中為變數 "%.*ls" 指定的值,無法用隱含方式轉換為該變數的類型。

4133

16

否

只有純量運算式可以指定為 RETURN 陳述式的引數。

4134

16

是

為資料表 '%.*ls' 中的計算資料行 '%.*ls' 所儲存在磁碟上的中繼資料,與資料行定義不符。為了避免可能的索引損毀問題,請卸除並重新建立此計算資料行。

4135

16

否

同義字 '%.*ls' 在佇列 '%.*ls' 上定義。不允許佇列上有同義字。

4136

16

否

提示 '%.*ls' 無法與提示 '%.*ls' 同時使用。

4137

16

否

格式檔案無法與 SINGLE_BLOB、SINGLE_CLOB 或 SINGLE_NCLOB 選項同時指定。

4138

16

否

資料表 "%.*ls" 已指定衝突鎖定提示。這可能是由檢視指定的衝突提示所導致。

4139

16

否

無法處理查詢,因為該查詢參考 Common Language Runtime (CLR) 資料表值函數 "%.*ls",並透過檢視 "%.*ls" 取得提示。

4140

15

否

INSERT 陳述式的目標資料表上,不允許 READCOMMITTEDLOCK 鎖定提示。

4141

16

否

不允許巢狀 CLR 類型更新。

4142

16

否

RECEIVE 清單中不允許彙總。

4143

16

否

大量 openrowset 提供者對 %.*ls 而言,不是有效的目標。

4144

16

否

插入遠端資料表時,不允許提示 '%.*ls'。

4145

15

否

有預期條件的內容中指定的非布林類型運算式,接近 '%.*ls'。

4146

16

否

統計資料只能建立在資料行上。

4147

15

否

查詢使用非 ANSI 外部聯結運算子 ("*=" 或 "=*")。若要不經修改即執行此查詢,請使用 ALTER DATABASE 的 SET COMPATIBILITY_LEVEL 選項,將目前資料庫的相容性層級設定為 80。我們強烈建議您使用 ANSI 外部聯結運算子 (LEFT OUTER JOIN、RIGHT OUTER JOIN),重新編寫查詢。SQL Server 的未來版本,將不再支援非 ANSI 聯結運算子,甚至在回溯相容性模式中都不支援。

4148

16

否

GROUP BY 子句中不允許 XML 方法。

4150

16

否

遞迴一般資料表運算式 (Common Table Expression,CTE) 參考不允許提示。請考慮是否移除遞迴 CTE 參考 '%.*ls' 的提示。

4151

16

否

NULLIF 的第一個引數類型不可以是 NULL 常數,因為第一個引數類型必須是已知的。

4152

16

否

類型 "%.*ls" 不是 CLR 類型。

4153

16

否

無法視資料類型 "%ls" 為資料類型 "%ls"。

4154

16

否

UNNEST 只能接受類型多重集的運算式。

4155

15

否

巢狀 INSERT 陳述式的 SELECT 清單只能包含一個項目。

4156

16

否

巢狀插入、巢狀更新或巢狀刪除的目標,均必須為多重集的類型。

4157

16

否

%.*ls 不是有效的屬性、欄位或方法。

4158

16

否

集清單中多次參考了欄位 "%.*ls",有直接參考也有透過屬性參考。

4159

16

否

延遲的 CLR 類型執行個體需要本機基底資料表資料行做為引數。

4160

16

否

資料表 '%.*ls' 中找不到合適的索引鍵來用於延遲的 CLR 類型提取。

4161

16

否

延遲的 CLR 類型提取只允許 CLR 類型。

4162

16

否

PROB_MATCH 資料表只能用於 PROB_MATCH 查詢的內部。

4163

16

否

PROB_MATCH 查詢中需要 GROUP BY 子句。

4164

16

否

PROB_MATCH 查詢中的 GROUP BY 子句只能有索引鍵資料行,且必須包含所有的索引鍵資料行。

4165

16

否

分數覆寫引數若出現在其中一個子查詢,就必須出現在所有的子查詢中,且必須具有相同的常數和變數。

4166

16

否

無效的 PROB_MATCH 子查詢。

4167

16

否

多個 PROB_MATCH 子查詢只能參考到相同的基底資料表。

4168

16

否

PROB_MATCH SELECT 清單中無效的 PROB_MATCH 專案項目。

4169

16

否

全文檢索屬性參考中,不允許多次套用 TREAT 到同一個運算式。

4170

16

否

(ANY) 規格只能套用到類型多重集的運算式。

4171

16

否

PROB_MATCH SELECT 清單中的彙總未指定別名。

4172

16

否

全文檢索 %s 的使用不正確。

4173

16

否

%.*s 不是有效的計分函數名稱。

4174

16

否

延遲的 CLR 類型具現化提取值查詢只能參考大型物件或大數值類型的資料行。

4175

16

否

無法在不是 Format.Structured 的 CLR 類型上執行巢狀更新。

4176

16

否

類型 "Simple" 的 FULLTEXTTABLE 指定了太多參數。參數的最大數目為 %d。

4177

16

否

PROB_MATCH 查詢的 FROM 子句必須由單一衍生資料表組成。

4184

16

否

無法為查詢作業擷取資料表資料,因為資料表 "%.*ls" 的結構描述更動太頻繁。由於資料表 "%.*ls" 包含篩選的索引或篩選的統計資料,因此變更資料表結構描述後必須重新整理資料表的所有資料。請重試一次查詢作業,如果問題仍然存在,請使用 SQL Server Profiler 找出造成問題的結構描述改變作業。

4185

16

否

無法在系統類型上執行這個動作。

4186

16

否

OUTPUT 子句中無法參考資料行 '%ls.%.*ls',因為此資料行定義包含子查詢,或者參考了執行使用者或系統資料存取的函數。函數如果不是結構描述繫結,根據預設會假設為要執行資料存取。請考慮從此資料行定義移除子查詢或函數,或者從 OUTPUT 子句移除此資料行。

4202

16

否

無法進行 BACKUP LOG,因為資料庫有大量記錄變更,且有一或多個檔案群組無法使用。

4208

16

否

當復原模式為 SIMPLE 時,不允許使用陳述式 %hs。請使用 BACKUP DATABASE 或使用 ALTER DATABASE 來變更復原模式。

4212

16

否

無法備份 master 資料庫的記錄檔。已改用 BACKUP DATABASE。

4214

16

否

無法執行 BACKUP LOG,因為沒有目前的資料庫備份。

4215

10

否

由於記錄檔開始處的資料為暫止的複寫項目或異動資料擷取,所以記錄檔並未截斷。請確定記錄讀取器代理程式或擷取工作是否在執行,或使用 sp_repldone 把交易標示為分散式或擷取式。

4217

10

否

由於這是唯讀的資料庫,所以 BACKUP LOG 無法修改資料庫。仍會繼續備份,不過後續的備份作業將會重複此備份內的工作。

4218

16

否

資料庫中有大量記錄作業。請執行 BACKUP LOG。

4302

16

否

選項 "%ls" 與線上還原衝突。請移除衝突選項並重新發出命令。

4303

16

否

向前復原目前的起始點位於記錄序號 (LSN) %.*s。必須有超過 LSN %.*s 的其他向前復原,才能完成還原順序。

4305

16

否

這個備份組的記錄從 LSN %.*ls 開始,但距離目前太近,無法套用至資料庫。請改用較早期且含有 LSN %.*ls 的記錄備份進行還原。

4307

16

否

線上還原至資料庫 '%ls' 失敗。執行離線還原可能較為恰當。若要強制離線還原,請先使用 ALTER DATABASE 陳述式,讓資料庫離線。

4308

10

否

線上還原已經完成,但是指定了 WITH NORECOVERY。請使用 RESTORE WITH RECOVERY 讓受影響的資料上線。

4309

16

否

檔案 "%ls" 的狀態不允許還原個別頁面。目前只能還原檔案。

4310

16

否

不允許在檔案 "%ls" 上執行 RESTORE PAGE,因為檔案不在線上。

4311

16

否

不允許在舊版的 SQL Server 備份中使用 RESTORE PAGE。

4312

16

否

本記錄檔無法還原,因為記錄檔鏈結中產生間距。請使用較新的資料備份來填補間距。

4315

10

否

某些檔案仍需要更多的還原步驟,線上還原順序才能完成。

4318

16

否

檔案 '%ls' 已向前復原至 LSN %.*ls。這個記錄檔結束於 LSN %.*ls,若要套用 WITH RECOVERY 選項則還太早。請重新發出 RESTORE LOG 陳述式 WITH NORECOVERY。

4319

16

否

先前的還原作業已中斷,且檔案 '%ls' 未處理完成。請還原中斷的備份組,或者重新啟動還原順序。

4320

16

否

檔案 "%ls" 未從資料庫或檔案還原中完全還原。整個檔案必須成功還原,才能套用此備份組。

4322

10

否

這個備份組包含在指定的時間點之前記錄的記錄。資料庫仍停留在還原狀態,以便執行更多的向前復原。

4323

16

否

之前的 RESTORE WITH CONTINUE_AFTER_ERROR 作業導致資料庫處於可能已損毀的狀態。若要繼續使用這個 RESTORE 順序,未來的所有步驟都必須包括 CONTINUE_AFTER_ERROR 選項。

4326

16

否

這個備份組的記錄於 LSN %.*ls 結束,要套用到資料庫還太早。可還原包含 LSN %.*ls 的較新記錄備份。

4327

16

否

此備份組的記錄包含大量記錄變更。禁止時間點復原。資料庫已向前復原至記錄結尾。

4328

16

否

遺漏檔案 "%ls"。向前復原於記錄序號 %.*ls 停止。檔案於記錄序號 (LSN) %.*ls 建立,於 LSN %.*ls 卸除。請將交易記錄還原至卸除檔案的時間點之前,或者還原資料以便與資料庫中的其他資料一致。

4329

10

否

這個記錄檔包含在指定的標示之前所記錄 (log) 的記錄 (record)。資料庫仍停留在還原狀態,以便您套用其他記錄檔。

4330

16

否

此備份組所在的復原路徑與資料庫不一致,因此無法套用。復原路徑是將資料庫帶領到特定復原點的資料與記錄備份順序。請找出相容的備份進行還原,或者將資料庫的其他部分還原以符合此備份組內的復原點,這將會還原資料庫到不同時間點。如需有關復原路徑的詳細資訊,請參閱《SQL Server 線上叢書》。

4331

16

否

由於檔案已還原為不一致的時間點,所以無法復原該資料庫。

4332

16

否

RESTORE LOG 已經暫止。若要以目前的狀態使用此資料庫,請執行 RESTORE DATABASE %ls WITH RECOVERY。

4333

16

否

此資料庫無法復原,因為記錄檔未還原。

4334

16

否

命名的標示未識別有效的 LSN。

4335

16

否

指定的 STOPAT 時間太早。整個資料庫或其中一部分已經向前復原超過該時間點。

4336

16

否

檔案群組 "%ls" 已卸除,無法還原到線上資料庫中。

4337

16

否

檔案 "%ls" 已卸除,無法還原到線上資料庫中。

4338

16

否

STOPAT 子句指定的時間點太早,無法還原此備份組。請選擇其他停止點,或使用 RESTORE DATABASE WITH RECOVERY 在目前點復原。

4339

10

否

這個 RESTORE 陳述式成功執行了一些動作,但是由於需要一或多個 RESTORE 步驟,因此無法讓資料庫上線。先前的訊息指出為何無法在此時復原的原因。

4340

16

否

此 RESTORE 陳述式的時間點子句,僅限由 RESTORE LOG 陳述式使用。請省略該子句或使用包含時間戳記的子句。

4341

16

否

此記錄備份包含大量記錄變更。無法用來在任意時間點停止。

4342

16

否

無法執行時間點復原,除非主要檔案群組是還原順序的一部分。請省略時間點子句或還原主要檔案群組。

4343

16

否

資料庫已向前復原至此備份組的結尾,且超過指定的時間點。RESTORE WITH RECOVERY 可以用來接受目前的復原點。

4344

16

否

不允許在唯讀資料庫或檔案群組中使用 RESTORE PAGE。

4345

10

否

在 msdb..suspect_page 資料表中記錄資訊時發現問題。這個錯誤只會影響 suspect_page 資料表的維護,不會影響其他任何活動。請檢查錯誤記錄檔,以取得詳細資訊。

4346

16

否

使用簡單復原模式的資料庫不允許使用 RESTORE PAGE。

4347

16

否

目前還原順序在轉換為線上狀態期間已被中斷。可以使用 RESTORE DATABASE WITH RECOVERY 來完成轉換為線上。

4348

16

否

線上還原至資料庫 '%ls' 失敗。執行離線還原可能較為恰當。使用 BACKUP LOG WITH NORECOVERY 即可起始離線還原。

4349

16

否

這個備份組的記錄從 LSN %.*ls 開始,但距離目前太近,無法套用至資料庫。此還原順序必須將記錄初始化為從 LSN %.*ls 開始。請使用更早的記錄備份重新發出 RESTORE LOG 陳述式。

4350

16

否

RESTORE PAGE 陳述式提供的頁面清單格式不正確。在此問題之前,已正確識別 %d 個頁面。問題發生在字元位移 %d。請檢查所有頁面是否都由數值 <file>:<page> 配對識別,且每對之間用半型逗點隔開。例如:PAGE='1:57,2:31'。

4351

16

否

SQL Server 舊版所接受的備份,fn_dump_dblog 並不支援。

4352

16

否

這個資料備份不支援 RESTORE LOG,因為檔案 '%ls' 太舊。請使用一般記錄備份繼續還原順序。

4353

16

否

已為檔案 '%.*ls' 指定衝突的檔案重新定位。您只能為任何邏輯檔案名稱指定一個 WITH MOVE 子句。

4354

10

是

因為資料庫正在從舊版升級,'%ls' 還原資料庫的 '%.*ls' 檔案仍停留在無用狀態。在涉及升級的情況下不允許分次還原。

4355

16

否

還原命令指定錯誤。RESTORE 陳述式的格式必須是: RESTORE DATABASE <x> FROM DATABASE_SNAPSHOT = <y>。

4356

10

否

資料庫 '%ls' 的還原已完成。此資料庫現在已可供使用。

4357

16

否

還原無法將 '%ls' 設為離線,因為有需要記錄備份的變更。請取得記錄備份,然後重試一次 RESTORE。

4358

16

否

無法將資料庫設為離線,因為檔案 '%ls' 目前已還原至 LSN %.*ls,但它其實必須還原至 LSN %.*ls。

4359

16

否

STOPAT 選項無法用於這個部分還原順序,因為未包含一或多個 FILESTREAM 檔案群組。CONTINUE_AFTER_ERROR 選項可用來強制復原,但這應該只用在以後不打算還原 FILESTREAM 檔案群組的情況。

4360

16

否

RESTORE LOG WITH CONTINUE_AFTER_ERROR 失敗。已中止執行 RESTORE 命令。

4403

16

否

無法更新檢視或函數 '%.*ls',因為其中包含彙總、DISTINCT 或 GROUP BY 子句,或 PIVOT 或 UNPIVOT 運算子。

4405

16

否

檢視或函數 '%.*ls' 不是可更新的,因為修改會影響多個基底資料表。

4406

16

否

由於內含衍生或常數欄位,導致檢視或函數 '%.*ls' 的更新或插入失敗。

4408

19

是

太多資料表。查詢以及其中的檢視或函數超過了 %d 個資料表的限制。請修訂查詢以減少資料表數量。

4413

16

否

由於繫結錯誤,因此無法使用檢視或函數 '%.*ls'。

4414

16

否

無法為檢視或函數解析配置輔助資料表。已經超過單一查詢中的資料表最大數量 (%d)。

4415

16

否

檢視 '%.*ls' 不是可更新的,可能因為該檢視是以 WITH CHECK OPTION 建立,或者該檢視跨越以 WITH CHECK OPTION 建立的檢視,且目標資料表在結果查詢中參考多次而導致。

4416

16

否

UNION ALL 檢視 '%.*ls' 不是可更新的,因為定義中包含不允許的結構。

4417

16

否

衍生資料表 '%.*ls' 不是可更新的,因為定義中包含 UNION 運算子。

4418

16

否

衍生資料表 '%.*ls' 不是可更新的,因為其中包含彙總、DISTINCT 或 GROUP BY 子句,或 PIVOT 或 UNPIVOT 運算子。

4420

16

否

衍生資料表 '%.*ls' 不是可更新的,因為修改會影響多個基底資料表。

4421

16

否

衍生資料表 '%.*ls' 不是可更新的,因為衍生資料表的某個資料行是衍生的或常數。

4422

16

否

檢視 '%.*ls' 有一個 INSTEAD OF UPDATE 觸發程序,且無法做為 UPDATE FROM 陳述式的目標。

4423

16

否

檢視 '%.*ls' 有一個 INSTEAD OF DELETE 觸發程序,且無法做為 DELETE FROM 陳述式的目標。

4424

16

否

聯結的資料表無法在包含外部聯結運算子的查詢中指定。檢視或函數 '%.*ls' 包含聯結的資料表。

4425

16

否

無法在包含聯結的資料表之查詢中指定外部聯結運算子。檢視或函數 '%.*ls' 包含外部聯結運算子。

4426

16

否

檢視 '%.*ls' 不是可更新的,因為定義中包含 UNION 運算子。

4427

16

否

無法更新檢視 "%.*ls",因為該檢視或其參考的檢視是以 WITH CHECK OPTION 建立而成,且其定義中包含 TOP 子句。

4429

16

否

檢視或函數 '%.*ls' 包含自我參考。檢視或函數不得直接或間接參考本身。

4430

10

否

警告: 將忽略提供給檢視 '%.*ls' 的索引提示。

4431

16

否

資料分割檢視 '%.*ls' 不是可更新的,因為資料表 '%.*ls' 內含時間戳記資料行。

4432

16

否

資料分割檢視 '%.*ls' 不是可更新的,因為資料表 '%.*ls' 內含 DEFAULT 條件約束。

4433

16

否

由於資料表 '%.*ls' 內含有 IDENTITY 條件約束,所以無法 INSERT 到資料分割的檢視 '%.*ls'。

4434

16

否

資料分割檢視 '%.*ls' 不是可更新的,因為資料表 '%.*ls' 內含 INSTEAD OF 觸發程序。

4435

16

否

資料分割的檢視 '%.*ls' 不是可更新的,因為未指定資料分割資料行 '%.*ls' 的值。

4436

16

否

UNION ALL 檢視 '%.*ls' 不是可更新的,因為找不到資料分割資料行。

4437

16

否

資料分割的檢視 '%.*ls' 做為大量作業的目標時不是可更新的。

4438

16

否

資料分割檢視 '%.*ls' 不是可更新的,因為該檢視並未傳遞其成員資料表的所有資料行。

4439

16

否

資料分割檢視 '%.*ls' 不是可更新的,因為來源查詢中包含資料分割資料表 '%.*ls' 的參考。

4440

16

否

UNION ALL 檢視 '%.*ls' 不是可更新的,因為在資料表 '%.*ls' 中找不到主索引鍵。

4441

16

否

資料分割檢視 '%.*ls' 不是可更新的,因為資料表 '%.*ls' 有計算資料行的索引。

4442

16

否

UNION ALL 檢視 '%.*ls' 不是可更新的,因為基底資料表 '%.*ls' 已經使用多次。

4443

16

否

UNION ALL 檢視 '%.*ls' 不是可更新的,因為基底資料表 '%.*ls' 的資料行 '%.*ls' 已經使用多次。

4444

16

否

UNION ALL 檢視 '%.*ls' 不是可更新的,因為資料表 '%.*ls' 的主索引鍵不在聯集結果內。

4445

16

否

UNION ALL 檢視 '%.*ls' 不是可更新的,因為資料表 '%.*ls' 的主索引鍵未與先前資料表的主索引鍵聯集。

4446

16

否

無法更新 UNION ALL 檢視 "%.*ls",因為檢視 "%.*ls" 中資料行 "%.*ls" 的定義已由另一個檢視表資料行使用。

4447

16

否

檢視 '%.*ls' 不是可更新的,因為定義中包含固定的運算子。

4448

16

否

由於未提供所有資料行的值,所以無法 INSERT 到資料分割的檢視 '%.*ls'。

4449

16

否

不允許在含有固定的運算子之檢視中使用預設值。

4450

16

否

由於資料表 '%.*ls' 中之檢視表資料行 '%.*ls' 的定義有 IDENTITY 條件約束,所以無法更新資料分割檢視 '%.*ls'。

4451

16

否

參考多伺服器上之資料表的檢視,無法在此版的 SQL Server 執行個體 '%.*ls' 上更新。請參閱線上叢書,以取得不同 SQL Server 版本所支援之功能的詳細資料。

4452

16

否

由於資料表 '%.*ls' 有 CASCADE DELETE 或 CASCADE UPDATE 條件約束,所以無法 UPDATE 檢視 '%.*ls' 的資料分割資料行 '%.*ls'。

4453

16

否

由於資料表 '%.*ls' 有 INSERT、UPDATE 或 DELETE 觸發程序,所以無法 UPDATE 檢視 '%.*ls' 的資料分割資料行 '%.*ls'。

4454

16

否

無法更新資料分割檢視 "%.*ls",因為該檢視的成員資料表中,有類型不符的資料分割資料行。

4456

16

否

資料分割的檢視 "%.*ls" 不是可更新的,因為其成員資料表中有一或多個非資料分割資料行的類型不符。

4457

16

否

嘗試為資料分割的檢視進行插入或更新失敗,因為資料分割資料行的值不屬於任何一個資料分割。

4502

16

否

檢視或函數 '%.*ls' 指定的資料行名稱數量大於所定義的資料行。

4503

16

否

由於 schemabound %S_MSG '%.*ls' 參考另一個資料庫的物件,因此無法建立。

4504

16

否

無法建立 %S_MSG '%.*ls',因為 CLR 類型 '%.*ls' 在目標資料庫 '%.*ls' 中不存在。

4505

16

否

CREATE VIEW 失敗,因為檢視 '%.*ls' 中的資料行 '%.*ls' 超過 %d 個資料行的最大限制。

4506

16

否

每一個檢視或函數中的資料行名稱必須是唯一的。檢視或函數 '%.*ls' 中的資料行名稱 '%.*ls' 已指定多次。

4508

16

否

暫存資料表不允許檢視或函數。以 '#' 開頭的資料表名稱代表暫存資料表。

4510

16

否

無法執行 CREATE VIEW,因為指定了 WITH %ls 且檢視不是可更新的。

4511

16

否

建立檢視或函數失敗,因為欄 %d 未指定資料行名稱。

4512

16

否

無法結構描述繫結 %S_MSG '%.*ls',因為名稱 '%.*ls' 對結構描述繫結而言是無效的。名稱的格式必須包含兩個部分,且物件不得自我參考。

4513

16

否

無法結構描述繫結 %S_MSG '%.*ls'。'%.*ls' 不是結構描述繫結。

4514

16

否

CREATE FUNCTION 失敗,因為未指定欄 %d 的資料行名稱。

4515

16

否

CREATE FUNCTION 失敗,因為函數 '%.*ls' 的資料行 '%.*ls' 超過 %d 個資料行的最大限制。

4516

16

否

由於含有 EXECUTE 陳述式,所以無法結構描述繫結函數 '%.*ls'。

4517

16

否

schemabinding 運算式中無法使用服務佇列物件。'%.*ls' 是服務佇列。

4519

16

否

無法在檢視 '%.*ls' 中 %S_MSG %S_MSG '%.*ls',因為該檢視由系統產生,目的是為了達到最佳化。

4520

16

否

無法停用檢視 '%.*ls' 上的索引,因為該檢視由系統產生,目的是為了達到最佳化。

4521

16

否

無法在 schemabinding 運算式中,搭配 autodrop 物件屬性使用物件 '%.*ls',因為該檢視由系統產生,目的是為了達到最佳化。

4522

16

否

無法改變檢視 '%.*ls',因為該檢視由系統產生,目的是為了達到最佳化。

4523

16

否

無法建立檢視 '%.*ls' 上的觸發程序,因為該檢視由系統產生,目的是為了達到最佳化。

4602

14

否

只有具備系統管理員 (sysadmin) 角色的成員才能授與或撤銷 CREATE DATABASE 權限。

4604

16

否

使用者或群組 '%.*ls' 不存在,或是您沒有權限。

4606

16

否

所授與或撤銷的權限 %ls 與物件不相容。

4610

16

否

您只能授與或撤銷目前資料庫中之物件的權限。

4611

16

否

若要撤銷或拒絕可授與的權限,請指定 CASCADE 選項。

4613

16

否

同意授權者沒有 GRANT 權限。

4615

16

否

無效的資料行名稱 '%.*ls'。

4616

16

否

您無法為資源資料庫執行此作業。

4617

16

否

無法授與、拒絕或撤銷特殊角色的權限。

4618

16

否

您沒有在 AS 子句中使用 %.*ls 的權限。

4619

16

否

只能在 master 資料庫授與 CREATE DATABASE 權限。

4620

16

否

授與/拒絕/撤銷陳述式中的所有權限,應該在相同的範圍內 (例如,伺服器或資料庫)

4621

16

否

只有當目前資料庫為 master 時,才能授與伺服器範圍的權限

4622

16

否

伺服器範圍的權限只能授與登入

4623

16

否

所有權限已被取代,此實體類別無法使用

4624

16

否

無法授與、拒絕或撤銷 sa、dbo、實體擁有者、information_schema、sys 或自己的權限。

4625

16

否

伺服器主體 %.*s 不存在,或是您沒有權限。

4627

16

否

無法授與、拒絕、或撤銷角色和應用程式角色的連接資料庫權限。

4628

16

否

ALL 權限已被取代,只是為了相容性而保留。此權限不代表實體上定義的 ALL 權限。

4629

16

否

伺服器範圍目錄檢視、系統預存程序或擴充預存程序的權限,只有當目前資料庫為 master 時才可授與。

4701

16

否

找不到物件 "%.*ls",原因是物件不存在,或您沒有權限。

4707

16

否

無法截斷物件 '%.*ls',因為該物件或它其中的一個索引位於 READONLY 檔案群組 '%.*ls' 上。

4708

16

否

無法截斷物件 '%.*ls',因為它不是資料表。

4709

16

否

您不可截斷系統資料表 '%.*ls'。

4710

16

否

無法截斷物件 '%.*ls',因為該物件或其中一個索引位於離線檔案群組 '%.*ls'。

4711

16

否

無法截斷資料表 '%.*ls',因為該資料表已發行供複寫或已啟用供異動資料擷取之用。

4712

16

否

無法截斷資料表 '%.*ls',因為該資料表正由 FOREIGN KEY 條件約束參考。

4801

16

否

此存取通訊協定不支援大量插入。

4802

16

否

SINGLE_LOB、SINGLE_CLOB 和 SINGLE_NCLOB 選項與其他所有選項互斥。

4803

21

是

大量複製 (bcp) 用戶端已送出資料列長度 %d。這是無效的大小。資料列的最大長度為 %d。請使用支援的用戶端應用程式發展介面 (API)。

4804

21

是

從主機讀取目前資料列時,發現訊息不當結束--伺服器需要看到更多資料時,內送的資料流卻被中斷。主機程式可能已經結束。請確定是使用支援的用戶端應用程式發展介面 (API)。

4805

17

否

您所使用的前端工具不支援從主機大量載入。請使用支援的工具來執行此命令。

4806

16

否

SINGLE_CLOB 需要雙位元組字集 (DBCS) (char) 輸入檔。指定的檔案為 Unicode。

4807

21

是

大量複製 (bcp) 用戶端傳送的資料列長度為 %d。這個大小無效。資料列大小的下限為 %d。請使用支援的用戶端應用程式發展介面 (API)。

4808

16

否

大量複製作業無法觸發大量載入陳述式。

4809

16

否

SINGLE_NCLOB 需要 UNICODE (widechar) 輸入檔。指定的檔案非 Unicode。

4810

16

否

需要資料流中的 TEXT Token 來進行 text 或 image 資料的大量複製。

4811

16

否

需要資料流中的資料行位移來進行 text 或 image 資料的大量複製。

4812

16

否

需要資料流中的資料列位移來進行 text 或 image 資料的大量複製。

4813

16

否

需要資料流中的文字長度來進行 text、ntext、或 image 資料的大量複製。

4814

16

否

下層用戶端不支援大量複製到資料分割資料表。

4815

16

否

從 colid %d 的 bcp 用戶端收到無效的資料行長度。

4816

16

否

來自 colid %d bcp 用戶端的資料行類型無效。

4817

16

否

無法大量載入。排序資料行 '%.*ls' 無效。已忽略 ORDER 提示。

4818

16

否

無法大量載入。排序資料行 '%.*ls' 已指定一次以上。已忽略 ORDER 提示。

4819

16

否

無法大量載入,大量資料流不正確地指定為已排序,或者此資料違反了目標資料表所設定的唯一性條件約束。下列兩個資料列的排序次序不正確: 第一列的主索引鍵: %s,第二列的主索引鍵: %s。

4820

16

否

無法大量載入,未知的格式檔案 "%s" 版本。

4821

16

否

無法大量載入,從格式檔案 "%s" 讀取資料行數目時發生錯誤。

4822

16

否

無法大量載入,格式檔案 "%s" 的資料行數目無效。

4823

16

否

無法大量載入,格式檔案 "%s" 有無效資料行編號。

4824

16

否

無法大量載入,資料行編號 %d 的資料類型於格式檔案 "%s" 中無效。

4825

16

否

無法大量載入,資料行編號 %d 的前置詞於格式檔案 "%s" 中無效。

4826

16

否

無法大量載入。資料行編號 %d 的資料行長度於格式檔案 "%s" 中無效。

4827

16

否

無法大量載入,資料行編號 %d 的資料行結束字元於格式檔案 "%s" 中無效。

4828

16

否

無法大量載入,來源欄 %d 的目的地資料表資料行編號於格式檔案 "%s" 中無效。

4829

16

否

無法大量載入,讀取格式檔案 "%s" 中來源欄 %d 的目的地資料表資料行名稱時,發生錯誤。

4830

10

否

大量載入: DataFileType 不正確地指定成 char。於資料檔案具有 Unicode 簽章,因此 DataFileType 將假設為 widechar。

4831

10

否

大量載入: DataFileType 不正確地指定成 widechar。由於資料檔案沒有 Unicode 簽章,因此 DataFileType 將假設成 char。

4832

16

否

大量載入: 資料檔中發現未預期的檔案結尾。

4833

16

否

大量載入: 提供者動態連結程式庫與伺服器可執行檔之間的版本不符。

4834

16

否

您沒有大量載入陳述式的使用權限。

4835

16

否

下層用戶端不支援大量複製到具有計算資料行的資料表。

4836

10

否

警告: 已發行資料表 "%.*s" 進行合併式複寫。請重新初始化受影響的訂閱者,或執行 sp_addtabletocontents,以確保下一次同步處理包含已加入的資料。

4837

16

否

無法大量複製至資料表 "%.*s",該資料表已啟用進行立即更新訂閱。

4838

16

否

大量資料來源並未支援 SQLNUMERIC 或 SQLDECIMAL 的資料類型。

4839

16

否

無法執行大量載入,來源欄 %d 的定序名稱於格式檔案 "%s" 中無效。

4840

16

否

大量資料來源提供者字串具有無效的 %ls 屬性值 %ls。

4841

16

否

資料來源名稱並非單純的物件名稱。

4842

16

否

伺服器提供者字串中遺漏必要的 FormatFile 屬性。

4843

16

否

大量資料來源提供者字串於字元位置 %d 附近發生語法錯誤 ('%lc')。

4844

16

否

大量資料來源提供者字串具有不支援的屬性名稱 (%ls)。

4845

16

否

大量資料來源提供者字串於字元位置 %d 附近發生語法錯誤。應該是 '%lc',但為 '%lc'。

4846

16

否

大量資料提供者無法配置記憶體。

4847

16

否

早於 SQL Server 2000 的版本不支援大量複製到具有 bigint 資料行的資料表。

4848

16

否

早於 SQL Server 2000 的版本不支援大量複製到具有 sql_variant 資料行的資料表。

4855

16

否

格式檔案 "%ls" 的行 %d: 未預期的元素 "%ls"。

4856

16

否

格式檔案 "%ls" 的行 %d: 未預期的資訊項目。

4857

16

否

格式檔案 "%ls" 的行 %d: 無法為此類型指定屬性 "%ls"。

4858

16

否

格式檔案 "%ls" 的行 %d: 屬性 "%ls" 的值 "%ls" 不正確。

4859

16

否

格式檔案 "%ls" 的行 %d: 遺漏所需的屬性 "%ls"。

4860

16

否

無法大量載入,檔案 "%ls" 不存在。

4861

16

否

無法大量載入,因為檔案 "%ls" 無法開啟。作業系統錯誤碼 %ls。

4862

16

否

無法大量載入,因為無法讀取檔案 "%ls"。作業系統錯誤碼 %ls。

4863

16

否

大量載入資料轉換錯誤 (截斷) 於列 %d,欄 %d (%ls)。

4864

16

否

大量載入資料轉換錯誤 (類型不符或指定字碼頁的字元無效) 於列 %d,欄 %d (%ls)。

4865

16

否

無法大量載入,因為已超過最大錯誤數目 (%d)。

4866

16

否

大量載入失敗,資料檔案的資料行對於列 %d,欄 %d 而言太長。請確定已指定正確的欄位結束字元和資料列結束字元。

4867

16

否

大量載入資料轉換錯誤 (溢位) 於列 %d,欄 %d (%ls)。

4868

16

否

大量載入失敗,尚未安裝字碼頁 "%d"。請安裝字碼頁,然後再次執行命令。

4869

16

否

大量載入失敗,資料檔於列 %d,欄 %d 發現未預期的 NULL 值。目的地資料行 (%ls) 定義為 NOT NULL。

4870

16

否

無法大量載入,因為寫入檔案 "%ls" 時發生錯誤。作業系統錯誤碼 %ls。

4871

16

否

嘗試記錄錯誤時發生大量載入錯誤。

4872

16

否

格式檔案 "%ls" 的行 %d: 重複的元素識別碼 "%ls"。

4873

16

否

格式檔案 "%ls" 的行 %d: 參考不存在的元素識別碼 "%ls"。

4874

16

否

格式檔案 "%ls" 的行 %d: 重複的元素識別碼參考 "%ls"。

4875

16

否

來自 colid %d 的 bcp 用戶端的資料行屬性無效。

4876

16

否

SQL Server 目的地的大量插入作業逾時。請考慮在資料流程中的 SQL Server 目的地上增加 Timeout 屬性的值。

4877

16

否

讀取列 %d、欄 %d 時,剖析 DTS 資料流發生錯誤。

4880

16

否

無法大量載入。在使用 FIRSTROW 和 LASTROW 參數時,FIRSTROW 的值不得大於 LASTROW 的值。

4881

10

否

注意: 透過檢視來大量插入,可能會造成資料檔案中的基底資料表預設值被當作 NULL 資料行而被忽略。

4882

16

否

無法大量載入。格式檔案 "%s" 的來源欄 %d 需要前置長度、欄位長度或結束字元。

4883

16

否

XML 讀取器針對傳回 0x%08X 給格式檔案 "%ls" 中開始於行 %d 欄 %d 附近的資訊項目。

4884

16

否

格式檔案 "%ls" 中開始於行 %d 欄 %d 附近的資訊項目發生未知錯誤。

4885

16

否

無法開啟檔案 "%ls"。需要 Windows NT 整合式安全性登入。

4886

16

否

無法開啟檔案 "%ls"。作業系統錯誤: %ls

4887

16

否

無法開啟檔案 "%ls"。僅支援磁碟檔案。

4888

16

否

無法開啟檔案 "%ls"。需要 bulkadmin 角色成員資格。

4889

16

否

無法開啟檔案 "%ls"。遺漏 unicode 位元組順序標示。

4890

16

否

執行程序表模式中不支援大量插入。

4891

16

否

由於目標資料表結構描述變更,大量插入失敗。

4892

16

否

由於目標資料表結構描述變更,大量插入失敗。

4893

16

否

無法大量載入,因為無法開啟 SSIS 檔案對應物件 '%ls'。作業系統錯誤碼 %ls。請確定是透過 Windows 安全性存取本機伺服器。

4894

21

是

使用 bcp 時必須有 COLMETADATA。

4895

21

是

欄 %d 的 Unicode 資料是奇數位元組大小,應該為偶數位元組大小。

4896

16

否

來自 colid %d bcp 用戶端的資料行值無效。

4897

16

否

收到長度無效的 colid %d 的區塊 LOB 資料。

4900

16

否

資料表 '%.*ls' 的 ALTER TABLE SWITCH 陳述式失敗。已啟用變更追蹤的資料表無法切換資料分割。使用 ALTER TABLE SWITCH 前,請先停用變更追蹤。

4901

16

否

ALTER TABLE 只允許加入可包含 Null 或已指定 DEFAULT 定義的資料行,或加入的資料行是識別或時間戳記資料行,或者,如果上述條件都不符合,資料表就必須是空的,以允許加入此資料行。資料行 '%.*ls' 無法加入至非空白資料表 '%.*ls',因為它不符合這些條件。

4902

16

否

找不到物件 "%.*ls",原因是物件不存在,或您沒有權限。

4903

10

否

警告: ALTER TABLE SWITCH 陳述式中忽略資料表 '%.*ls' 的指定資料分割 %d,因為資料表並未分割。

4904

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 的指定資料分割 %d 必須是空的。

4905

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 必須是空的。

4906

16

否

'%ls' 陳述式失敗。%S_MSG '%.*ls' 為 %S_MSG 已分割,而索引 '%.*ls' 為 %S_MSG 已分割。

4907

16

否

'%ls' 陳述式失敗。%S_MSG '%.*ls' 有 %d 資料分割,而索引 '%.*ls' 有 %d 資料分割。

4908

16

否

'%ls' 陳述式失敗。用來分割 %S_MSG '%.*ls' 的範圍界限值與用來分割索引 '%.*ls' 的範圍界限值不同。

4909

16

否

無法改變 '%.*ls',因為它並不是資料表。

4911

16

否

無法在沒有資料分割編號的 ALTER TABLE SWITCH 陳述式中,指定資料分割資料表。資料表 '%.*ls' 已分割。

4912

16

否

'%ls' 陳述式失敗。用來分割 %S_MSG '%.*ls' 的資料行集與用來分割索引 '%.*ls' 的資料行集不同。

4913

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 有叢集索引 '%.*ls',而資料表 '%.*ls' 沒有叢集索引。

4914

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 "%.*ls" 有已停用的叢集索引。

4915

16

否

'%ls' 陳述式失敗。用來分割 %S_MSG '%.*ls' 的資料分割函數參數類型,與用來分割索引 %.*ls' 的資料分割函數參數類型不同。

4916

16

否

無法啟用或停用條件約束。請查看先前的錯誤。

4917

16

否

條件約束 '%.*ls' 並不存在。

4918

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料表 '%.*ls' 上有全文檢索索引。

4919

16

否

無法在資料行 '%.*ls' 上改變 PERSISTED 屬性,因為這個資料行並未進行計算。

4920

16

否

ALTER TABLE 失敗,因為資料表 '%.*ls' 上的觸發程序 '%.*ls' 並不存在。

4921

16

否

ALTER TABLE 失敗,因為觸發程序 '%.*ls' 不屬於資料表 '%.*ls'。

4922

16

否

%ls %.*ls 失敗,因為有一或多個物件存取這個資料行。

4923

16

否

ALTER TABLE DROP COLUMN 失敗,因為 '%.*ls' 是資料表 '%.*ls' 中唯一的資料行。資料表必須至少有一個資料行。

4924

16

否

%ls 失敗,因為資料行 '%.*ls' 於資料表 '%.*ls' 中並不存在。

4925

16

否

ALTER TABLE ALTER COLUMN ADD ROWGUIDCOL 失敗,因為資料表 '%.*ls' 已經有屬性為 ROWGUIDCOL 的資料行。

4926

16

否

ALTER TABLE ALTER COLUMN DROP ROWGUIDCOL 失敗,因為資料表 '%.*ls' 並沒有屬性為 ROWGUIDCOL 的資料行。

4927

16

否

無法將資料行 '%.*ls' 的資料類型改變為 %.*ls。

4928

16

否

無法改變資料行 '%.*ls',因為它是 '%ls'。

4929

16

否

無法改變 %S_MSG '%.*ls',因為它正在發行,以進行複寫。

4933

16

否

已計算的資料行 '%.*ls' 於資料表 '%.*ls' 中無法保存,因為該資料行與非結構描述繫結物件相依。

4934

16

否

已計算的資料行 '%.*ls' 於資料表 '%.*ls' 中無法保存,因為該資料行執行使用者或系統資料存取。

4935

16

否

ALTER TABLE ADD COLUMN 不能指定異於現有檔案群組的 FILESTREAM 檔案群組。

4936

16

否

資料表 '%.*ls' 中的計算資料行 '%.*ls' 無法保存,因為該資料行不具決定性。

4938

16

否

ALTER TABLE SWITCH 陳述式失敗。%S_MSG '%.*ls' 的資料分割 %d 在檔案群組 '%.*ls' 中,而 %S_MSG '%.*ls' 的資料分割 %d 則在檔案群組 '%.*ls' 中。

4939

16

否

ALTER TABLE SWITCH 陳述式失敗。%S_MSG '%.*ls' 在檔案群組 '%.*ls' 中,而 %S_MSG '%.*ls' 的資料分割 %d 則在檔案群組 '%.*ls' 中。

4940

16

否

ALTER TABLE SWITCH 陳述式失敗。%S_MSG '%.*ls' 在檔案群組 '%.*ls' 中,而 %S_MSG '%.*ls' 則在檔案群組 '%.*ls' 中。

4941

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料表 '%.*ls' 已標示為要進行合併式複寫。

4942

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料表 '%.*ls' 序數 %d 的資料行 '%.*ls' 與資料表 '%.*ls' 相同序數的資料行 '%.*ls' 有不同的名稱。

4943

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料表 '%.*ls' 有 %d 資料行,而資料表 '%.*ls' 有 %d 資料行。

4944

16

否

ALTER TABLE SWITCH 陳述式失敗,因為來源資料表 '%.*ls' 中,資料行 '%.*ls' 有資料類型 %s,此資料類型與目標資料表 '%.*ls' 中的類型 %s 不同。

4945

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中具有的定序不同。

4946

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中具有的保存屬性不同。

4947

16

否

ALTER TABLE SWITCH 陳述式失敗。來源資料表 '%.*ls' 中的索引與目標資料表 '%.*ls' 中的索引 '%.*ls' 不是完全相同。

4948

16

否

ALTER TABLE SWITCH 陳述式失敗。來源資料表 '%.*ls' 在資料庫 '%.*ls' 中,而目標資料表 '%.*ls' 在資料庫 '%.*ls' 中。

4949

16

否

ALTER TABLE SWITCH 陳述式失敗,因為物件 '%.*ls' 不是使用者自訂資料表。

4950

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料分割編號 %d 不存在於資料表 '%.*ls' 中。

4951

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中具有的 FILESTREAM 儲存體屬性不同。

4952

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中具有的 ansi 修剪語意不同。

4953

16

否

ALTER TABLE SWITCH 陳述式失敗。用來分割資料表 '%.*ls' 的資料行集與用來分割資料表 '%.*ls' 的資料行集不同。

4954

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 對資料列資料中的文字有內嵌限制 %d,與資料表 '%.*ls' 所使用的值 %d 不同。

4955

16

否

ALTER TABLE SWITCH 陳述式失敗。來源資料表 '%.*ls' 和目標資料表 '%.*ls' 相同。

4956

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料表 '%.*ls' 不是 RANGE 資料分割。

4957

16

否

'%ls' 陳述式失敗,因為識別 %S_MSG '%.*ls' 資料分割編號的運算式不是整數類型。

4958

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中具有的 ROWGUIDCOL 屬性不同。

4959

16

否

ALTER TABLE SWITCH 陳述式失敗。%S_MSG '%.*ls' 的資料分割 %d 有 TEXT 檔案群組 '%.*ls',而 %S_MSG '%.*ls' 的資料分割 %d 則有 TEXT 檔案群組 '%.*ls'。

4960

16

否

ALTER TABLE SWITCH 陳述式失敗。檢查條件約束 '%.*ls' 於來源資料表 '%.*ls' 中為 NOCHECK 條件約束,而對應的檢查條件約束 '%.*ls' 於目標資料表 '%.*ls' 中則為 CHECK。

4961

16

否

ALTER TABLE SWITCH 陳述式失敗。資料行 '%.*ls' 於資料表 '%.*ls' 中可為 Null,而它在 '%.*ls' 中則不可以是 Null。

4962

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 中的資料分割 %d,不是定界資料分割。

4963

16

否

ALTER TABLE SWITCH 陳述式失敗。資料分割 %d 對資料表 '%.*ls' 無效。

4964

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 有 RULE 條件約束 '%.*ls'。SWITCH 不允許在有 RULE 條件約束的資料表上。

4965

16

否

ALTER TABLE SWITCH 陳述式失敗。資料行 '%.*ls' 於資料表 '%.*ls' 中是已計算的資料行,但在 '%.*ls' 中相同的資料行則尚未計算。

4966

16

否

ALTER TABLE SWITCH 陳述式失敗。已計算的資料行 '%.*ls' 於資料表 '%.*ls' 中定義為 '%.*ls',此資料行異於資料表 '%.*ls' 中定義為 '%.*ls' 的相同資料行。

4967

16

否

ALTER TABLE SWITCH 陳述式失敗。不允許 SWITCH,因為來源資料表 '%.*ls' 包含條件約束 '%.*ls' 的主索引鍵。

4968

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 有條件約束 '%.*ls' 的外部索引鍵,但來源資料表 '%.*ls' 沒有對應的索引鍵。

4969

16

否

ALTER TABLE SWITCH 陳述式失敗。外部索引鍵條件約束 '%.*ls' 於來源資料表 '%.*ls' 中停用,而對應的條件約束 '%.*ls' 則在目標資料表 '%.*ls' 中啟用。來源資料表條件約束必須加以啟用。

4970

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 有資料表層級檢查條件約束 '%.*ls',但來源資料表 '%.*ls' 沒有對應的條件約束。

4971

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 有資料行層級檢查條件約束 '%.*ls',但來源資料表 '%.*ls' 沒有對應的條件約束。

4972

16

否

ALTER TABLE SWITCH 陳述式失敗。來源資料表 '%.*ls' 的檢查條件約束或資料分割函數所允許的值,目標資料表 '%.*ls' 的檢查條件約束或資料分割函數並不允許。

4973

16

否

ALTER TABLE SWITCH 陳述式失敗。資料分割 %d 於資料表 '%.*ls' 中所定義的範圍不是資料分割 %d 於資料表 '%.*ls' 中所定義的範圍子集。

4974

16

否

ALTER TABLE SWITCH 陳述式失敗。外部索引鍵條件約束 '%.*ls' 於來源資料表 '%.*ls' 中為 NOCHECK,而對應的條件約束 '%.*ls' 於目標資料表 '%.*ls' 中為 CHECK。來源資料表條件約束必須為 CHECK。

4975

16

否

ALTER TABLE SWITCH 陳述式失敗。來源資料表 '%.*ls' 的檢查條件約束 '%.*ls' 與目標資料表 '%.*ls' 的檢查條件約束 '%.*ls' 有不同的 'Not For Replication' 設定。

4976

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 在 XML 資料行上有檢查條件約束 '%.*ls',但來源資料表 '%.*ls' 沒有完全相同的檢查條件約束。

4977

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 在 CLR 類型資料行上有檢查條件約束 '%.*ls',但來源資料表 '%.*ls' 沒有完全相同的檢查條件約束。

4978

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 中的資料分割 %d 存在唯讀檔案群組 '%.*ls' 中。

4979

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 存在於唯讀檔案群組 '%.*ls' 中。

4980

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 中的資料分割 %d 在唯讀檔案群組 '%.*ls' 中存在 lobdata。

4981

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 的 lobdata 存在於唯讀檔案群組 '%.*ls' 中。

4982

16

否

ALTER TABLE SWITCH 陳述式失敗。來源資料表 '%.*ls' 的檢查條件約束所允許的值,於目標資料表 '%.*ls' 資料分割 %d 上定義的範圍並不允許。

4983

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 上有 XML 或空間索引 '%.*ls'。只有來源資料表才可以在 ALTER TABLE SWITCH 陳述式中有 XML 或空間索引。

4984

16

否

ALTER TABLE SWITCH 陳述式失敗。目標資料表 '%.*ls' 和來源資料表 '%.*ls' 的 Vardecimal 儲存格式值不相同。請使用 sp_tableoption 預存程序改變資料表的 [Vardecimal 儲存格式] 選項,以確定兩個值相同。

4985

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中具有的 Null 屬性不同。

4986

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中的 CLR 類型不同。

4987

16

否

ALTER TABLE SWITCH 陳述式失敗,因為資料行 '%.*ls' 在資料表 '%.*ls' 和 '%.*ls' 中具有的 XML 結構描述集合不同。

4988

16

否

無法保存已計算的資料行 '%.*ls'。基礎物件 '%.*ls' 的擁有者與資料表 '%.*ls' 不同。

4989

16

否

無法於資料表 '%.*ls' 中卸除資料行 '%.*ls' 的 ROWGUIDCOL 屬性,因為資料行不是為該資料表的指定 ROWGUIDCOL。

4990

16

否

無法於資料表 '%.*ls' 中改變資料行 '%.*ls',以加入或移除 FILESTREAM 資料行屬性。

4991

16

否

無法於資料表 '%.*ls' 中改變資料行 '%.*ls' 上的 NOT FOR REPLICATION 屬性,因為這個資料行不是識別欄位。

4992

16

否

無法在未包含任何大型數值類型 varchar(max)、nvarchar(max)、varbinary(max)、xml 或大型 CLR 類型資料行的使用者資料表上使用資料表選項 LARGE VALUE TYPES OUT OF ROW。這個選項可以套用到具有保存的大型數值計算資料行的資料表。

4993

16

否

ALTER TABLE SWITCH 陳述式失敗。資料表 '%.*ls' 的 Large Value Types Out Of Row 資料表選項設定,在比較之下與資料表 '%.*ls' 的設定不同。

4994

16

否

無法保存資料表 '%.*ls' 中的計算資料行 '%.*ls',因為資料行類型 '%.*ls' 是非位元組排序的 CLR 類型。

4995

16

否

資料表 '%.*ls' 上無法啟用 VarDecimal 儲存格式,因為資料庫 '%.*ls' 是系統資料庫。系統資料庫不提供 Vardecimal 儲存格式。

4996

16

否

資料表 '%.*ls' 已啟用變更追蹤。

4997

16

否

無法在資料表 '%.*ls' 上啟用變更追蹤。變更追蹤要求資料表必須有主索引鍵。請在資料表上建立主索引鍵後,再啟用變更追蹤。

4998

16

否

資料表 '%.*ls' 未啟用變更追蹤。

4999

16

否

無法在資料表 '%.*ls' 上啟用變更追蹤。變更追蹤不支援資料表上使用時間戳記類型的主索引鍵。