X509CertSelector.AddSubjectAlternativeName Método
Definição
Importante
Algumas informações se referem a produtos de pré-lançamento que podem ser substancialmente modificados antes do lançamento. A Microsoft não oferece garantias, expressas ou implícitas, das informações aqui fornecidas.
Sobrecargas
| Nome | Description |
|---|---|
| AddSubjectAlternativeName(Int32, Byte[]) |
Adiciona um nome ao critério subjectAlternativeNames. |
| AddSubjectAlternativeName(Int32, String) |
Adiciona um nome ao critério subjectAlternativeNames. |
AddSubjectAlternativeName(Int32, Byte[])
Adiciona um nome ao critério subjectAlternativeNames.
[Android.Runtime.Register("addSubjectAlternativeName", "(I[B)V", "GetAddSubjectAlternativeName_IarrayBHandler")]
public virtual void AddSubjectAlternativeName(int type, byte[]? name);
[<Android.Runtime.Register("addSubjectAlternativeName", "(I[B)V", "GetAddSubjectAlternativeName_IarrayBHandler")>]
abstract member AddSubjectAlternativeName : int * byte[] -> unit
override this.AddSubjectAlternativeName : int * byte[] -> unit
Parâmetros
- type
- Int32
o tipo de nome (0-8, conforme listado acima)
- name
- Byte[]
uma matriz de bytes que contém o nome no formulário codificado em ASN.1 DER
- Atributos
Exceções
se a decodificação do nome falhar.
Comentários
Adiciona um nome ao critério subjectAlternativeNames. O X509Certificate deve conter todos ou pelo menos um dos SubjectAlternativeNames especificados, dependendo do valor do sinalizador matchAllNames (consulte #setMatchAllSubjectAltNames setMatchAllSubjectAltNames).
Esse método permite que o chamador adicione um nome ao conjunto de nomes alternativos de assunto. O nome especificado é adicionado a qualquer valor anterior para o critério subjectAlternativeNames. Se o nome especificado for duplicado, ele poderá ser ignorado.
O nome é fornecido como uma matriz de bytes. Essa matriz de bytes deve conter o nome codificado em DER, como seria exibido na estrutura GeneralName definida em RFC 5280 e X.509. A matriz de bytes codificada deve conter apenas o valor codificado do nome e não deve incluir a marca associada ao nome na estrutura GeneralName. A definição asn.1 dessa estrutura aparece abaixo.
{@code
GeneralName ::= CHOICE {
otherName [0] OtherName,
rfc822Name [1] IA5String,
dNSName [2] IA5String,
x400Address [3] ORAddress,
directoryName [4] Name,
ediPartyName [5] EDIPartyName,
uniformResourceIdentifier [6] IA5String,
iPAddress [7] OCTET STRING,
registeredID [8] OBJECT IDENTIFIER}
}
Observe que a matriz de bytes fornecida aqui é clonada para proteger contra modificações subsequentes.
Documentação Java para java.security.cert.X509CertSelector.addSubjectAlternativeName(int, byte[]).
Partes desta página são modificações baseadas no trabalho criado e compartilhado pelo Project Open Source do Open Source e usadas de acordo com os termos descritos na Creative Commons 2.5.
Aplica-se a
AddSubjectAlternativeName(Int32, String)
Adiciona um nome ao critério subjectAlternativeNames.
[Android.Runtime.Register("addSubjectAlternativeName", "(ILjava/lang/String;)V", "GetAddSubjectAlternativeName_ILjava_lang_String_Handler")]
public virtual void AddSubjectAlternativeName(int type, string? name);
[<Android.Runtime.Register("addSubjectAlternativeName", "(ILjava/lang/String;)V", "GetAddSubjectAlternativeName_ILjava_lang_String_Handler")>]
abstract member AddSubjectAlternativeName : int * string -> unit
override this.AddSubjectAlternativeName : int * string -> unit
Parâmetros
- type
- Int32
o tipo de nome (0-8, conforme especificado no RFC 5280, seção 4.2.1.6)
- name
- String
o nome na forma de cadeia de caracteres (não null)
- Atributos
Exceções
se a análise do nome falhar.
Comentários
Adiciona um nome ao critério subjectAlternativeNames. O X509Certificate deve conter todos ou pelo menos um dos SubjectAlternativeNames especificados, dependendo do valor do sinalizador matchAllNames (consulte #setMatchAllSubjectAltNames setMatchAllSubjectAltNames).
Esse método permite que o chamador adicione um nome ao conjunto de nomes alternativos de assunto. O nome especificado é adicionado a qualquer valor anterior para o critério subjectAlternativeNames. Se o nome especificado for duplicado, ele poderá ser ignorado.
O nome é fornecido no formato de cadeia de caracteres. Os nomes RFC 822, DNS e URI usam os formatos de cadeia de caracteres bem estabelecidos para esses tipos (sujeitos às restrições incluídas no RFC 5280). Os nomes de endereço IPv4 são fornecidos usando a notação quad pontilhada. Os nomes de endereço OID são representados como uma série de inteiros nãonegativos separados por períodos. E os nomes de diretório (nomes diferenciados) são fornecidos no formato RFC 2253. Nenhum formato de cadeia de caracteres padrão é definido para outros Nomes, nomes X.400, nomes de partes EDI, nomes de endereço IPv6 ou qualquer outro tipo de nomes. Eles devem ser especificados usando o #addSubjectAlternativeName(int type, byte [] name) addSubjectAlternativeName(int type, byte [] name) método.
<Observação forte>:</forte> para nomes diferenciados, use #addSubjectAlternativeName(int, byte[]) em vez disso. Esse método não deve ser confiado, pois pode falhar ao corresponder a alguns certificados devido à perda de informações de codificação na forma de cadeia de caracteres RFC 2253 de alguns nomes diferenciados.
Partes desta página são modificações baseadas no trabalho criado e compartilhado pelo Project Open Source do Open Source e usadas de acordo com os termos descritos na Creative Commons 2.5.