Nota
O acesso a esta página requer autorização. Pode tentar iniciar sessão ou alterar os diretórios.
O acesso a esta página requer autorização. Pode tentar alterar os diretórios.
Este artigo resume a matriz de suporte e as limitações do uso de pontos de restauração de VM.
Matriz de suporte de pontos de restauração de VM
A tabela a seguir resume a matriz de suporte para pontos de restauração de VM.
| Cenários | Suportado por pontos de recuperação da VM |
|---|---|
| VMs que usam discos geridos | Sim |
| Máquinas virtuais que utilizam discos não geridos | Não |
| Tamanhos de VM | A consistência após falha é suportada nas SKUs de VM que suportam Armazenamento Premium. |
| VMs que utilizam Discos Ultra | Sim. Suporte para consistência de aplicação. Não suportado para consistência em caso de falhas. Exclua esses discos e crie um ponto de restauração de VM ao usar a consistência de falhas. |
| VMs que usam discos SSD Premium v2 | Sim. Suporte para consistência de aplicação. Não suportado para consistência em caso de falhas. Exclua esses discos e crie um ponto de restauração de VM ao usar a consistência de falhas. |
| VMs que utilizam Discos de SO Efémeros | N.º Exclua esses discos e crie um ponto de restauração de VM. |
| VMs que utilizam discos partilhados | N.º Exclua esses discos e crie um ponto de restauração de VM. |
| VMs com extensões | Sim |
| VMs com disco de sistema operativo de lançamento confiável | Sim |
| Discos de dados restaurados a partir de um disco do SO com arranque fidedigno ativado | Não |
| VMs confidenciais | Suportado apenas para a consistência das aplicações com tamanho da série v6 na região Norte dos Emirados Árabes Unidos e na Coreia Central (prévia) A série V5 não é suportada. Não suportado para consistência em caso de falhas. |
| VMs de Geração 2 (arranque UEFI) | Sim |
| VMs com discos NVMe (otimizados para armazenamento - série Lsv2) | Sim, para a Aplicação, é consistente. Não suportado para consistência em caso de falhas. |
| Arquitetura VM - x64 | Suporte consistente para aplicações e falhas. |
| Arquitetura VM - ARM64 | Aplicação suportada apenas para imagens Linux. |
| VMs em grupos de colocação por proximidade | Sim |
| VMs em um conjunto de disponibilidade | Sim. Você pode criar pontos de restauração de VM para VMs individuais dentro de um conjunto de disponibilidade. Você precisa criar pontos de restauração para todas as VMs dentro de um conjunto de disponibilidade para proteger uma instância inteira do conjunto de disponibilidade. |
| VMs num VMSS com orquestração uniforme | Não |
| VMs dentro de VMSS com orquestração flexível | Sim. Você pode criar pontos de restauração de VM para VMs individuais dentro do Virtual Machine Scale Set Flex. No entanto, é necessário criar pontos de restauração para todas as máquinas virtuais dentro do conjunto de escalonamento de máquinas virtuais flex a fim de proteger toda a instância do conjunto de escalonamento de máquinas virtuais flex. |
| VMs Spot (VMs de baixa prioridade) | Sim |
| VMs com hosts dedicados | Sim |
| VMs com o armazenamento em cache do anfitrião ativado | Sim |
| VMs criadas a partir de imagens do marketplace | Sim |
| VMs criadas a partir de imagens personalizadas | Sim |
| VM com a licença HUB (Hybrid Use Benefit) | Sim |
| VMs migradas do ambiente local com o Azure Migrate | Sim |
| VMs com políticas de RBAC | Sim |
| Disco temporário nas VMs | Sim. Você pode criar um ponto de restauração de VM para VMs com discos temporários. No entanto, os pontos de restauração criados não contêm os dados dos discos temporários. |
| VMs com HDDs Standard | Sim |
| VMs com SSDs Standard | Sim |
| VMs com SSD Premium | Sim |
| VMs com discos ZRS | Sim |
| VMs com encriptação do lado do servidor que utilizam chaves geridas pelo serviço | Sim. A encriptação do disco de origem não estará ativada no ponto de restauro. |
| VMs com encriptação do lado do servidor que utilizam chaves geridas pelo cliente | Sim. A encriptação do disco de origem não estará ativada no ponto de restauro. |
| VMs com dupla encriptação em repouso | Sim. A encriptação do disco de origem não estará ativada no ponto de restauro. |
| VMs com encriptação baseada no anfitrião ativada com encriptação PMK/CMK/dupla | Sim. A encriptação do disco de origem não estará ativada no ponto de restauro. |
| Máquinas virtuais com ADE (Azure Disk Encryption) | Sim. A encriptação do disco de origem não estará ativada no ponto de restauro. |
| VMs que utilizam Redes Aceleradas | Sim |
| Tamanhos de máquinas virtuais compatíveis com o Azure Boost | Sim, para a Aplicação, é consistente. Não suportado para consistência em caso de falhas. |
| Frequência mínima em que pode ser alcançado o ponto de restauro consistente da App | 3 horas |
| Frequência mínima com que podem ser criados pontos de restauro consistentes após falha | Uma hora |
| Versão da API para o ponto de restauro consistente da aplicação | 2021-03-01 ou posterior |
| Versão da API para ponto de restauro consistente para Crash | 2021-07-01 ou posterior |
| Acesso Instantâneo para VMs que usam SSD Premium v2 e/ou Ultra como discos de dados | Sim, para pontos de restauro consistentes com a aplicação. Versão API 2025-04-01 ou posterior. |
| Acesso instantâneo a pontos de restauro consistentes após falha | N.º |
Nota
Os Pontos de Restauração (consistentes com aplicações ou consistente com falhas) podem ser criados pelo cliente na frequência mínima suportada, conforme mencionado acima. A captura de pontos de restauração com uma frequência inferior à suportada resultará em erro.
Suporte ao sistema operacional para consistência de aplicativos
Windows
Os seguintes sistemas operacionais Windows são suportados ao criar pontos de restauração para VMs do Azure em execução no Windows.
- Cliente Windows 10 (apenas 64 bits)
- Windows Server 2022 (Datacenter/Datacenter Core/Standard)
- Windows Server 2019 (Datacenter/Datacenter Core/Standard)
- Windows Server 2016 (Datacenter/Datacenter Core/Standard)
- Windows Server 2012 R2 (Datacenter/Padrão)
- Windows Server 2012 (Datacenter/Padrão)
- OS que atingiram a atualização de segurança estendida não serão suportados. Verifique o ciclo de vida do seu produto aqui
Os pontos de restauro não suportam sistemas operativos de 32 bits.
Linux
Para VMs Linux da VM do Azure, os pontos de restauração dão suporte à lista de distribuições Linux endossadas pelo Azure. Tenha em atenção o seguinte:
- Os pontos de restauração não suportam Core OS Linux.
- Os pontos de restauro não suportam sistemas operativos de 32 bits.
- Outras distribuições Linux podem funcionar desde que o agente de VM do Azure para Linux esteja disponível na VM e desde que o Python seja suportado.
- Os pontos de restauração não suportam uma VM Linux configurada por proxy se ela não tiver o Python versão 2.7 ou superior instalado.
- Os pontos de restauração não fazem backup de arquivos NFS montados a partir do armazenamento ou de qualquer outro servidor NFS para máquinas Linux ou Windows. Ele só faz backup de discos que estão conectados localmente à VM.
Suporte de sistemas operativos para consistência pós-falha
- Todos os sistemas operacionais são suportados.
Outras limitações
- Os pontos de restauração são suportados apenas para discos gerenciados.
- Discos efêmeros do sistema operacional e discos compartilhados não são suportados por ambos os modos de consistência.
- As APIs de pontos de restauração exigem uma API da versão 2021-03-01 ou posterior para consistência do aplicativo.
- A API de pontos de restauro requer uma API da versão 2021-03-01 ou posterior para consistência em caso de falha.
- Um máximo de 10.000 coleções de pontos de restauração podem ser retidos por cada nível de subscrição e região.
- Um VM pode reter um máximo de 500 pontos de restauração a qualquer momento, independentemente do número de coleções de pontos de restauração.
- Não há suporte para a criação simultânea de pontos de restauração para uma VM.
- A movimentação de máquinas virtuais entre grupos de recursos ou assinaturas é suportada quando a VM tem pontos de restauração. A criação de um novo ponto de restauração falhará na VM anterior, pois a VM não existe mais após o movimento. Você precisa limpar a coleção de pontos de restauração e os pontos de restauração da VM antiga, se não forem mais necessários.
Máquinas Virtuais Confidenciais (Pré-visualização)
| Cenários | Suportado por pontos de recuperação da VM |
|---|---|
| Tipo de consistência | Pontos de restauro consistentes na aplicação |
| Regiões apoiadas | EAU Norte e Coreia Central |
| Tamanhos de VM |
A série V6 é suportada. A série V5 não é suportada. |
| Rotação de chaves | Supported. Quando ocorre rotação de chaves numa máquina virtual confidencial, as chaves dos discos da VM, pontos de restauro relacionados e instantâneos atualizam-se automaticamente. Problema conhecido: A rotação de chaves nesta versão de pré-visualização pode ter problemas de desempenho ou falhar nos seguintes cenários: - Mais de 40 discos estão ligados a um DES quando (apenas) pontos de restauro estão associados a estes discos. Se também criares snapshots de disco diretamente fora do backup Azure para esses discos ligados ao mesmo DES, isso reduz o limiar seguro de 40 discos para o mapeamento DES. Recomendação: Mantenha o número de discos ligados a cada DES ao mínimo até o problema ser resolvido. |
| Prerequisites | Antes de configurar backup para o CVM, certifique-se de que os seguintes pré-requisitos são cumpridos: Registe-se para a funcionalidade de pré-visualização na sua subscrição Azure - Nome: RestorePointSupportForConfidentialVMV2 Fornecedor: Microsoft.Compute. O registo é aprovado automaticamente. Pode seguir os passos aqui para fazer isto no portal.Também pode executar o seguinte cmdlet PowerShell. azurepowershell-interactive Register-AzProviderFeature -FeatureName "RestorePointSupportForConfidentialVMV2" -ProviderNamespace "Microsoft.Compute" Identifique ou crie uma VM Confidencial (CVM) numa região suportada. Consulte as regiões suportadas. |
Nota
A visualização pública da cópia entre regiões dos pontos de restauração da VM está disponível, com as seguintes limitações:
- Não há suporte para links privados ao copiar pontos de restauração entre regiões ou criar pontos de restauração em uma região diferente da VM de origem.
- Os pontos de restauração criptografados de chave gerenciados pelo cliente, quando copiados para uma região de destino ou criados diretamente na região de destino, são criados como pontos de restauração criptografados de chave gerenciados pela plataforma.
- Sem suporte de portal para cópia entre regiões e criação de pontos de restauração entre regiões
Próximos passos
- Saiba como criar pontos de restauração de VM usando a CLI, o portal do Azure e o PowerShell.